Command line doesn't use keywords

VERIFIED WONTFIX

Status

()

Toolkit
Startup and Profile System
--
enhancement
VERIFIED WONTFIX
13 years ago
10 years ago

People

(Reporter: Adam Bryzak, Assigned: Benjamin Smedberg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Firefox's command line processor doesn't allow the use of bookmark keywords to
start a site

Reproducible: Always

Steps to Reproduce:
1. Create a bookmark with a keyword (Firefox installs with a few such as
"google" for a google search
2. Open a command prompt
3. If the Firefox directory isn't in your path, go into the firefox directory
4. Start Firefox by typing "firefox <keyword>" or "firefox <keyword> <variable>"
(both cases without the quotes) where <keyword> is the keyword for the bookmark
that you made in step 1 and <variable> is an optional piece of text eg. "firefox
google Mozilla"

Actual Results:  
If a keyword and a variable are present, firefox doesn't open. If just a keyword
is present (1 parameter), firefox opens with the first result of a Google search
for the term.

Expected Results:  
It should check if the command line arguments have a keyword with an optional
variable and load te appropriate bookmark.

I have the "Force links that open in new windows to open in:" set to "a new tab"
and "Open links from other applications in:" set to "a new tab in the most
recent window" (in case this is the reason it doesn't start when more than 1
parameter is present)
(Assignee)

Comment 1

13 years ago
I'm inclined to wontfix this. URI params should be filenames or full URIs. We
could add a separate command-line flag -bookmark-keyword "<keyword> [param]" but
that sounds like feature-bloat overkill.
Agreed.  This is going a bit farther than we're going to go, and even though I
know I could find a use for this, its not something that really belongs in the core.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.