Include OS name in download links on multi-language-download-page

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
14 years ago
6 years ago

People

(Reporter: stian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
Index: mozilla-org/html/products/thunderbird/all.html
===================================================================
RCS file: /cvsroot/mozilla-org/html/products/thunderbird/all.html,v
retrieving revision 1.3
diff -u -r1.3 all.html
--- mozilla-org/html/products/thunderbird/all.html	31 Dec 2004 02:25:53 -0000	1.3
+++ mozilla-org/html/products/thunderbird/all.html	3 Jan 2005 15:37:24 -0000
@@ -116,9 +116,9 @@
           var code = language + "-" + region.toUpperCase();
           document.writeln("<tr><td>" + build.name + "</td><td lang=\"" + code
+ "\">" + build.localName + "</td>");
           if (build.official) {
-            document.writeln("<td><a href=\"" + getDownloadURLForLanguage(code,
PLATFORM_WINDOWS) + "\">Download</a></td>");
-            document.writeln("<td><a href=\"" + getDownloadURLForLanguage(code,
PLATFORM_MACOSX) + "\">Download</a></td>");
-            document.writeln("<td><a href=\"" + getDownloadURLForLanguage(code,
PLATFORM_LINUX) + "\">Download</a></td></tr>");
+            document.writeln("<td><a href=\"" + getDownloadURLForLanguage(code,
PLATFORM_WINDOWS) + "\">Windows</a></td>");
+            document.writeln("<td><a href=\"" + getDownloadURLForLanguage(code,
PLATFORM_MACOSX) + "\">OS X</a></td>");
+            document.writeln("<td><a href=\"" + getDownloadURLForLanguage(code,
PLATFORM_LINUX) + "\">Linux</a></td></tr>");
           } else {
             document.writeln("<td colspan='3'>Not Yet Available<\/td>");
           }

On the Thunderbird advanced download page, the problem is that after scrolling
to say "Norwegian", there's three "Download"-links, but it's impossible to know
which link is for Windows, MacOS or Linux unless scrolling up again.

The suggestion is to instead just print the OS name instead of thousands of
"Download" links.

The same problem applies to http://www.mozilla.org/products/firefox/all.html

Comment 1

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050811 Firefox/1.0+

Status: UNCONFIRMED -> RESOLVED
Resolution: --- -> WORKSFORME

Each Download link has an OS-specific image preceding it. The images have the OS
name as the alt attribute too.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

13 years ago
Agreed, this solution with small images work well.
Status: RESOLVED → VERIFIED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.