Mail crashed when trying to launch it.

VERIFIED FIXED

Status

P3
blocker
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: esther, Assigned: harishd)

Tracking

({smoketest})

Trunk
All
Linux
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
Using build 2000021409m14 build 
I crash when I click on Tasks|Mail on a existing.
I crash launching mozilla -messenger
I crash when I click on Tasks|Mail on a new profile

Can't launch mail, can't test.

Updated

19 years ago
Keywords: dogfood, smoketest
Hardware: HP → PC

Updated

19 years ago
Summary: Mail crashed when trying to launch it. → Linux: Mail crashed when trying to launch it.

Comment 1

19 years ago
I see this on my linux system as well.
(Reporter)

Comment 2

19 years ago
Talkback call id 5358256.  Thanks lisa for the keywords, I was looking up the 
talkback report.

Comment 3

19 years ago
Don't know if this will be of help:

   SinkContext::CloseContainer()                                    
   HTMLContentSink::CloseContainer() 
   CNavDTD::CloseContainer() 
   CNavDTD::CloseContainersTo() 
   CNavDTD::HandleDefaultStartToken() 
   CNavDTD::HandleStartToken() 
   CNavDTD::HandleToken() 
   CNavDTD::BuildModel() 
   nsParser::BuildModel() 
   nsParser::ResumeParse() 
   nsParser::OnDataAvailable() 
   nsDocumentOpenInfo::OnDataAvailable() 
   InterceptStreamListener::OnDataAvailable() 
   nsHTTPResponseListener::OnDataAvailable() 
   nsOnDataAvailableEvent::HandleEvent() 
   nsStreamListenerEvent::HandlePLEvent() 
   PL_HandleEvent() 
   PL_ProcessPendingEvents() 
   nsEventQueueImpl::ProcessPendingEvents() 
   event_processor_callback() 
   our_gdk_io_invoke() 
   libglib-1.2.so.0 + 0xe52a (0x406a852a) 
   libglib-1.2.so.0 + 0xfbe6 (0x406a9be6) 
   libglib-1.2.so.0 + 0x101a1 (0x406aa1a1) 
   libglib-1.2.so.0 + 0x10341 (0x406aa341) 
   libgtk-1.2.so.0 + 0x8c209 (0x405d1209) 
   nsAppShell::Run() 
   nsAppShellService::Run() 
   main1() 
   main() 
   libc.so.6 + 0x181eb (0x402201eb) 

I see it on the commercial build, I'm rebuilding my tree at home so I can fix
it.

accepting.
Status: NEW → ASSIGNED

Comment 5

19 years ago
I'm seeing it on NT as well. I submitted a Talkback incident, but it hasn't been 
digested yet.

Based on Lisa's stack trace, we need some Gecko help. Rick?
(Reporter)

Comment 6

19 years ago
Adding win32 platform to this bug, because it crashed on win98 too.  Reassigning 
to Phil too.
Assignee: sspitzer → phil
Status: ASSIGNED → NEW
OS: Linux → All
Hardware: PC → All
Summary: Linux: Mail crashed when trying to launch it. → Linux & Win32: Mail crashed when trying to launch it.
(Reporter)

Comment 7

19 years ago
Sorry, I reassinged it to phil before I read the comments.  Seth, you still want 
this?

Comment 8

19 years ago
I'm seeing it on NT as well. mStackPos is -1, which seems to be the cause of the 
problem.
OS: All → Linux
Hardware: All → PC
Summary: Linux & Win32: Mail crashed when trying to launch it. → Linux: Mail crashed when trying to launch it.
adding rickg to the cc list, since this might be his bug.

Comment 10

19 years ago
adding self to cc-list. Until this is fixed, I'm dead in the water since I'm 
working on a commercial tree feature.
Hardware: PC → All
Summary: Linux: Mail crashed when trying to launch it. → Mail crashed when trying to launch it.

Comment 11

19 years ago
I recall seeing in another bug yesterday that rick was out at training or 
something.  Just a fyi.

Comment 12

19 years ago
According to vidur, parser stuff goes to harishd
Assignee: phil → harishd

Comment 13

19 years ago
if you disable the mailnews start page, this crash goes away. But the mail/news 
start page loads fine in the browser, so it doesn't seem to be a problem with 
the content.

Comment 14

19 years ago
Putting on PDT+ radar.
Whiteboard: [PDT+]

Comment 15

19 years ago
the latest linux respin does not have this problem.
(Assignee)

Comment 16

19 years ago
Problem caused by NOSCRIPT tag which I had enabled late Friday.  Disabled 
NOSCRIPT, like before, and will investigate the problem in M15 (Ref. bug 21008)

Marking this bug FIXED.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

19 years ago
Win32 and linux verified with respins 2000-02-14=16 waiting for Mac now.

Comment 18

19 years ago
Esther passed the MAC 2000-02-15-09-M14 commercial build for mail smoketests so 
I'm marking verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.