[FIX] I want to open ONLY composer

RESOLVED FIXED in mozilla1.8beta1

Status

SeaMonkey
Installer
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: arinkleff, Assigned: bsmedberg)

Tracking

({helpwanted})

unspecified
mozilla1.8beta1
x86
All
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
I want to use composer without opening mozilla -- I do not like having the same
document open twice, its annoying to have to close it twice.

Comment 1

13 years ago
You can either use the -editor command line switch or use the option in the
Appearance pane of the Preferences dialog. Marking WORKSFORME.

Please read http://www.mozilla.org/quality/bug-writing-guidelines.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

13 years ago
command line switch??????????? The option in the appearance pane doesn't work --
i have it set to only open composer, but it opens mozilla anyways (and doesn't
open composer).  
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

13 years ago
Confirming bug, 2005-01-02-06 trunk Linux.
"mozilla -editor" opens a Navigator window.
Appearance pref. "Composer"  => Navigator window (only)
Appearance pref. "Composer+Navigator" => Navigator window (only)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All

Updated

13 years ago
Depends on: 272144

Comment 4

13 years ago
(In reply to comment #3)
> Confirming bug, 2005-01-02-06 trunk Linux.
> "mozilla -editor" opens a Navigator window.
> Appearance pref. "Composer"  => Navigator window (only)
> Appearance pref. "Composer+Navigator" => Navigator window (only)

All these things WFM with the exact same build, with the latest gtk2 nightly
2005010311 and with my self-compiled gtk2 build from yesterday.

Please make sure you don't add a -P command line switch when testing this,
because then you run into Bug 58523.

Comment 5

13 years ago
I did not use -P when testing.
I can confirm that the 2005-01-03-11 gtk2+xft nightly is working fine.
I retested 2005-01-02-06 with a completely empty HOME, e.g:

mkdir /tmp/bla
HOME=/tmp/bla /usr/local/mozilla/mozilla -editor

still does not work.
Now, here's the funny thing - if I install 2005-01-02-06 from the
"mozilla-i686-pc-linux-gnu.tar.gz" and retry the above it does work!
However, an installation (complete) from the
"mozilla-i686-pc-linux-gnu-full-installer.tar.gz"
(into an empty directory) does not work.

-> Installer (for further triage)
Assignee: composer → general
Component: Composer → Installer
QA Contact: bugzilla

Comment 6

13 years ago
this regressed between linux trunk 2004102906 and 2004103005, which is the
landing of bug 237745. But I don't know/why how that would single out the
intsaller build.
(Assignee)

Comment 7

13 years ago
I do. The composer command line handler was turned into a JS component, and that
needs to be packaged in the installer manifests.
Keywords: helpwanted
Assignee: general → benjamin
(Assignee)

Comment 8

13 years ago
Created attachment 172917 [details] [diff] [review]
Package the JS commandline handler
Attachment #172917 - Flags: review?(neil.parkwaycc.co.uk)

Comment 9

13 years ago
Comment on attachment 172917 [details] [diff] [review]
Package the JS commandline handler

Sorry, this is way out of my area. I don't even know if the package lists
should be grouped in any way (list the .js file near composer.dll perhaps?)
Attachment #172917 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Updated

13 years ago
Attachment #172917 - Flags: review?(timeless)

Updated

13 years ago
Flags: blocking1.8b?
Summary: I want to open ONLY composer → [FIX] I want to open ONLY composer

Updated

13 years ago
Attachment #172917 - Flags: review?(timeless) → review+
(Assignee)

Comment 10

13 years ago
Fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8beta

Updated

13 years ago
Flags: blocking1.8b?
You need to log in before you can comment on or make changes to this bug.