Using plugin finder to install plugins blocks all tabs in the window below

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
14 years ago
4 years ago

People

(Reporter: dascandy, Assigned: doronr)

Tracking

1.7 Branch
x86
Windows 2000

Details

(Reporter)

Description

14 years ago
This is very annoying when surfing using solely tabs, since you'd be stuck
waiting for the plugin finder to install something (in my case Java, which took
a while) where you'd really like not to be stuck there.

Comment 1

14 years ago
I had to spawn a new window in order to do any browsing while Flash was
downloading.  Why is this dialog modal?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

14 years ago
The reason was to simplify coding, since this was a last minute thing. 

I accept patches :)
Product: Firefox → Toolkit
Bug 836415 has now removed the Plugin Finder Service (PFS) from Firefox. As a result, I'm closing all the remaining PFS bugs.

If you're getting this bugmail for an ancient PFS bug, the basic summary of the world today is:

* NPAPI plugins are a dying technology
* PFS was already restricted to assisting with only the 4 most common plugins
* Sites commonly provide their own UI for install a required plugin
* Mozilla is generally focusing on  improving the web platform so that proprietary plugins are not required.

(Note that "plugins" are a completely separate from "browser extensions", such at those found on addons.mozilla.org. The latter are not going anywhere, and are not impacted by the removal of PFS.)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.