crash when trying to resize table

VERIFIED DUPLICATE of bug 273458

Status

SeaMonkey
Composer
--
critical
VERIFIED DUPLICATE of bug 273458
14 years ago
7 years ago

People

(Reporter: sairuh (rarely reading bugmail), Unassigned)

Tracking

({crash, regression, smoketest})

Trunk
crash, regression, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
hm, I couldn't find an existing bug for this, but pls dup as needed.

found using 2005010405-trunk gtk2 mozilla (1.8z6) build on linux fedora core 2.

1. create or open an existing page in composer.

2. insert a table (I clicked the Table button in the toolbar). I just used the
default settings and clicked OK.

3. click on the table to display the resize handles.

4. try to drag one of the resize handles (I tried ones on the outside of the
table to expand it).

results: crash.

http://talkback-reports.mozilla.org/talkback/quicksearch.jsp?search=2&type=iid&id=2917816

Stack Signature	 nsHTMLReflowState::GetContainingBlockFor() ae53a030
Product ID	MozillaTrunk
Build ID	2005010401
Trigger Time	2005-01-04 13:39:40.0
Platform	LinuxIntel
Operating System	Linux 2.6.9-1.11_FC2
Module	libgklayout.so + (000f438f)
URL visited	
User Comments	try to drag to resize (enlarge) table in composer
Since Last Crash	0 sec
Total Uptime	0 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.
/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/layout/generic/nsHTMLReflowState.cpp,
line 656
Stack Trace 	
nsHTMLReflowState::GetContainingBlockFor() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/layout/generic/nsHTMLReflowState.cpp,
line 656]
nsComputedDOMStyle::GetAbsoluteOffset() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/layout/style/nsComputedDOMStyle.cpp,
line 2974]
nsComputedDOMStyle::GetOffsetWidthFor() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/layout/style/nsComputedDOMStyle.cpp,
line 2955]
nsComputedDOMStyle::GetTop() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/layout/style/nsComputedDOMStyle.cpp,
line 2913]
nsComputedDOMStyle::GetPropertyCSSValue() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/layout/style/nsComputedDOMStyle.cpp,
line 311]
nsComputedDOMStyle::GetPropertyValue() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/layout/style/nsComputedDOMStyle.cpp,
line 272]
nsHTMLCSSUtils::GetCSSInlinePropertyBase() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/editor/libeditor/html/nsHTMLCSSUtils.cpp,
line 576]
nsHTMLCSSUtils::GetComputedProperty() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/editor/libeditor/html/nsHTMLCSSUtils.cpp,
line 842]
nsHTMLEditor::SetResizingInfoPosition() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/editor/libeditor/html/nsHTMLObjectResizer.cpp,
line 899]
nsHTMLEditor::MouseMove() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/editor/libeditor/html/nsHTMLObjectResizer.cpp,
line 908]
ResizerMouseMotionListener::MouseMove() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/editor/libeditor/html/nsHTMLObjectResizer.cpp,
line 92]
DispatchToInterface(nsIDOMEvent*, nsIDOMEventListener*, unsigned
(nsIDOMEventListener::*)() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/content/events/src/nsEventListenerManager.cpp,
line 136]
nsEventListenerManager::HandleEvent() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1607]
nsDocument::HandleDOMEvent() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/content/base/src/nsDocument.cpp,
line 3827]
nsGenericElement::HandleDOMEvent() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/content/base/src/nsGenericElement.cpp,
line 1935]
nsGenericElement::HandleDOMEvent() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/content/base/src/nsGenericElement.cpp,
line 848]
nsGenericElement::HandleDOMEvent() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/content/base/src/nsGenericElement.cpp,
line 848]
PresShell::HandleEventInternal() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/layout/base/nsPresShell.cpp,
line 848]
PresShell::HandleEvent() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/layout/base/nsPresShell.cpp,
line 5772]
nsViewManager::HandleEvent() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/view/src/nsViewManager.cpp,
line 848]
nsViewManager::DispatchEvent() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/view/src/nsViewManager.cpp,
line 100]
HandleEvent() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/view/src/nsView.cpp,
line 174]
nsCommonWidget::DispatchEvent() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/widget/src/gtk2/nsCommonWidget.cpp,
line 218]
nsWindow::OnMotionNotifyEvent() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/widget/src/gtk2/nsWindow.cpp,
line 1339]
motion_notify_event_cb() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/widget/src/gtk2/nsWindow.cpp,
line 3493]
libgtk-x11-2.0.so.0 + 0x112d64 (0x0304ed64)
libgobject-2.0.so.0 + 0x9160 (0x001d9160)
libgobject-2.0.so.0 + 0x1d168 (0x001ed168)
libgobject-2.0.so.0 + 0x1befe (0x001ebefe)
libgobject-2.0.so.0 + 0x1c424 (0x001ec424)
libgtk-x11-2.0.so.0 + 0x212655 (0x0314e655)
libgtk-x11-2.0.so.0 + 0x111302 (0x0304d302)
libgtk-x11-2.0.so.0 + 0x110056 (0x0304c056)
libgdk-x11-2.0.so.0 + 0x3e045 (0x00323045)
libglib-2.0.so.0 + 0x24252 (0x00cd1252)
libglib-2.0.so.0 + 0x25348 (0x00cd2348)
libglib-2.0.so.0 + 0x25680 (0x00cd2680)
libglib-2.0.so.0 + 0x25cc3 (0x00cd2cc3)
libgtk-x11-2.0.so.0 + 0x10f923 (0x0304b923)
nsAppShell::Run() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 141]
nsAppStartup::Run() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/xpfe/components/startup/src/nsAppStartup.cpp,
line 208]
main1() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 848]
main() 
[/builds/tinderbox/SeaMonkey-Release/Linux_2.4.20-28.8_Depend/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1814]
libc.so.6 + 0x14ad4 (0x00593ad4)
(Reporter)

Comment 1

14 years ago
marcia is able to crash this on Mac with today's seamonkey trunk. I'll get a
regression window in a bit...
OS: Linux → All
Hardware: PC → All

Comment 2

14 years ago
This is XP. I see it on windows, too.

Comment 3

14 years ago
regression happened between 11-20 and 11-29. there are no archived builds within
that window so that's the best we can do for binary checking.
(Reporter)

Updated

14 years ago
Keywords: regression

Comment 4

14 years ago
This is a big window with a lot of changes. Roc, dbaron, tor, matts, neil, and
bz, can you all look at this and see if it looks like something you touched. 

Regression seems to have happened in here:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=Head&sortby=Date&hours=2&date=explicit&mindate=2004-11-20+6%3A00&maxdate=2004-11-29+8%3A00
Keywords: regression
OS: All → Linux
Hardware: All → PC

Updated

14 years ago
Keywords: regression, smoketest
OS: Linux → All
Hardware: PC → All

Comment 5

14 years ago
This should block the release of 1.8a6. 
Flags: blocking1.8a6+
I fixed this earlier today...

*** This bug has been marked as a duplicate of 273458 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

14 years ago
Status: RESOLVED → VERIFIED

Updated

14 years ago
Flags: blocking1.8a6+
You need to log in before you can comment on or make changes to this bug.