Strange behavior when textarea contains markup control characters

RESOLVED DUPLICATE of bug 227358

Status

()

--
minor
RESOLVED DUPLICATE of bug 227358
14 years ago
14 years ago

People

(Reporter: crisp, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

429 bytes, text/html
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

First of all: yes, markup-significant control characters should be represented
by their entities when used in form controls. However, there seems to be some
strange inconsistent behavior with certain combinations of characters as show on
the testpage.

For instance, this is no problem for the rendering engine; it correctely assumes
that the lower-than sign is content en not a control character:

<textarea rows="5" cols="60"><- no problem here</textarea>

however when the lower-than is followed by a question mark, or an exclamation
mark things go wrong in the sense that all following HTML is suddenly also
considered content:

<textarea rows="5" cols="60"><? question mark triggers the problem?</textarea>

Reproducible: Always

Steps to Reproduce:
1. See testpage
Actual Results:  
All markup following a combination of < followed by a ? or ! is considered
content for the textarea

Expected Results:  
It should use some form of error-correction to prevent this problem as it does
in other cases (consistent behavior when there is no ambiguity)
(Reporter)

Comment 1

14 years ago
Created attachment 170280 [details]
Testcase

Added testpage for convenience
This is a duplicate of bug 227358, and that bug was fixed by bug 88952.

*** This bug has been marked as a duplicate of 227358 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.