downloadable files with names like '-[number]'.[file_extension]' are automatically incremented incorrectly by the download manager.

VERIFIED DUPLICATE of bug 231048

Status

()

--
major
VERIFIED DUPLICATE of bug 231048
14 years ago
10 years ago

People

(Reporter: staylor, Assigned: bugs)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
For example:  A file stored on my server is named 'PDF-01234-1.pdf'.  I have a
link on my webpage that allows a user to access this file.  

The first time they click on the link to get the file in a Firefox browser, the
correct file with the correct filename is saved to the client's desktop. If they
 repeat this process, a file named 'PDF-01234-2.pdf' appears on the client's
desktop.  

The file is the same in every way as the first download, except the name is
different.  (This only happens if the file 'PDF-01234-1.pdf' exists on the
desktop when it is accessed for the second time, and if I hover over the link in
my browser, it always displays 'PDF-01234-1.pdf' as the file being accessed).    

In other browsers (Safari), the file is either automatically incremented like: 
'PDF-01234-1-1.pdf' (first time downloaded)
'PDF-01234-1-2.pdf' (second time downloaded to the same destination, with the
first file existing already in that destination).  Or, as is the case in Mozilla
1.3.1, a 'save-as' box automatically prompts the client to rename the file like:
'PDF-01234-1-1.pdf', or if the new '-1' extension is removed by the user, it
alerts the user that the first file will be overwritten the second time the
download is attempted with that filename.  
(In IE, the PDF is visible in the browser).

It seems as though the behavior in Firefox could be seen as a feature,
eliminating the step for the user of incrementing filenames, however, this is a
big problem for us, as 'PDF-01234-1.pdf' is a completely different PDF than
'PDF-01234-2.pdf'.  If the browser automatically named the files like:
'PDF-01234-1-1.pdf'
'PDF-01234-1-2.pdf' 
then we would be happy.  These filenames are different enough from our
convention to alert the user that they have 2 copies of the same file on their
desktop, rather than 2 different files.

Thank you in advance for your time,
S. Taylor

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 231048 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: downloadable files with names like '-[number]'.[file_extension]' are automatically incremented incorrectly by the download manager. → downloadable files with names like '-[number]'.[file_extension]' are automatically incremented incorrectly by the download manager.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.