View separate calendars in separate views (e.g. side by side, not overlayed) [extension fodder]

RESOLVED WONTFIX

Status

Calendar
Calendar Views
--
enhancement
RESOLVED WONTFIX
13 years ago
3 years ago

People

(Reporter: ericbonney, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Details

(Whiteboard: [extension fodder])

(Reporter)

Description

13 years ago
Currently if you subcribe to multiple calendars, then all the events for all
calendars are showed lumped together inside each view.  It would be easier to
see if each seperate calendar had its own "view", similar to Outook.  This may
acuallty be something that more properly belongs in an extension and not part of
the core product, but it still would be very helpful.
You can use the checkboxes in the calendars tab for that.
Assignee: shaver → mostafah
Component: Base → Sunbird and Calendar-Extension Front End
QA Contact: base → brantgurganus2001
(Reporter)

Comment 2

13 years ago
Yes, I know you can use the checkboxes for that, but it is alot of checking and
unchecking if you have many people that are sharing calendars.  If there were an
extension or part of the core then the view would be more useable.

As an example, we have 4 people in our office that we share the calendars with.
 We do this so that we can keep track of staff.  It is much easier to set an
appointment for a staff member if I see only his/her calendar, but if I also
need to say go with that staff memeber I also need to see my calendar.  I
understand this can be done with the current feature set and maybe it would just
take getting used to.  

I also belive that since it is something that would benefit a small number of
people it should be done as an extension, which means it would have to wait
until that part of Sunbird is ready.

Updated

12 years ago
QA Contact: gurganbl → sunbird
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
Blocks: 373033
Component: Sunbird Only → Calendar Views
OS: Windows XP → All
QA Contact: sunbird → views
Hardware: PC → All
Version: Sunbird 0.2RC1 → unspecified

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

11 years ago
I have to exact same request from a client and seeing
http://forums.mozillazine.org/viewtopic.php?t=548082
more people would like to have this. 
Depends on: 513536
This could probably happen nicely in a new tab, see bug 513536 and bug 513537.
Depends on: 513537

Comment 6

6 years ago
Can this request be re-evaluated now in 2011, now with Lightning 1.0 being near? I am also looking for a view similar to what Outlook does. Having multiple calendars side by side (or in views/tabs) helps to separate different contexts.

Updated

5 years ago
Duplicate of this bug: 787772

Updated

5 years ago
Summary: View Seperate calendars in seperate views → View separate calendars in separate views (e.g. side by side, not overlayed)
I think this should be solved with multiple tabs. There is simply not enough room to show two calendars next to each other on a small screen. For large screens, a second window might help.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 513536

Comment 9

3 years ago
Hi Philipp,

unfortunately this is NOT a duplicate of bug 513536 due to 2 reasons:

1. This bug describes a different use case.
2. "Allow multiple calendar tabs" is not implemented, therefore the base issue is not resolved and there is no workaround.

The side-by-side view as described here is for parallel comparative view of multiple calenders like it is implemented by Outlook and several WebApp Groupwares. This is a logical AND.

Using multiple tabs implements a logical XOR - you can show only 1 calendar at a time.

Tabs *might* work if there is a split-screen view - implemented as a variant of MDI. Please see http://en.wikipedia.org/wiki/Comparison_of_document_interfaces for an introduction.
Hi Nikolaus,

I'm aware this is not exactly a duplicate, but the alternative is WONTFIX with [extension fodder]. I understand that a split screen with separate calendars might be nice, but I don't think it should be part of the core product. If we have a split screen view, then we also need a second calendar list. This adds a lot of complexity for a feature not useful for everyone.

If you want something like a side-by-side view in the core product, then you could follow bug 332401. You could open a new window and arrange them separately. This already kind of works, although there may be bugs:

1. Go to mail view
2. right click on any folder
3. Open folder in new window
4. Open the calendar tab.

I understand that neither bug 332401 nor bug 513536 is fixed yet, but under the premise that one of those bugs covers the use case in this bug, I don't think we should keep all three open.

I hope this explains it a bit better and alleviates your concerns.

Comment 11

3 years ago
Hi Philipp,

thank you for your fast and complete answer.

As you seem to acknowledge that this ticket is different from the two others it is a little bit odd (if not to say 'self-deceiving') to close this valid ticket. It only results in cleaning valid requests from the list and almost losing the history of the feature request.

Your proposed workaround is very user unfriendly (eg. it wastes a lot of screen space and needs manual positioning) - even if it "somehow works" .

My dream is still to have the best features known from other PIM products in TB+lightning. MS Outlook has only 1 list of calendars (with the option to add groups of calendars) and each enabled calendar opens in a new side-by-side tab first. Each tab has an arrow button to merge the contents of the selected calendar into the main calendar tab. This is not very complex from UX, but very flexible.

I'm not deep enough into lightning or mozilla community to argue more in favor of this topic or to understand your point regarding the inclusion in core or not.

I would still recommend to leave that open so that an interested developer can see the requested options and chose one to implement bringing the overall features forward.

Thank you. Best regards,
Ok, how about this: I'm marking this bug as I would any other bug I think should rather be an extension, and will put comments into the multi-window bug to reference the discussion here. This way developers can find the bug when searching for extension ideas and it will not be forgotten when we get to the window/tab code.

As for positioning, I know windows has a mode where you can just drag a window to the edge of a screen and it will put it on one side of the screen. About user friendlyness of what I suggested, I know its not ideal to need to open a new window using the folder context menu, hence its only a workaround and not a fix. The fix for that would be to add UI to the calendar tab or context menus to open the calendar in a new window and should be taken care of in bug 332401.

If an extension is created and it turns out the extension is used by a large number of users, we can still reconsider adding it back into the core product.
Resolution: DUPLICATE → WONTFIX
Summary: View separate calendars in separate views (e.g. side by side, not overlayed) → View separate calendars in separate views (e.g. side by side, not overlayed) [extension fodder]
Whiteboard: [extension fodder]
You need to log in before you can comment on or make changes to this bug.