Crash at loading this page

VERIFIED WORKSFORME

Status

()

Core
XBL
P3
critical
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Pierre Saslawsky)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
When you go to the page, Mozilla will crash at loading.

Steps of reproduce
1. Launch Mozilla
2. Go to above URL
Mozilla will crash.

Stacktrace incident 5362454
 Trigger Type:  Program Crash 

 Trigger Reason:  SIGSEGV: Segmentation Fault: (signal 11) 

 Call Stack:    (Signature = 0x00000015 1199699e) 
     
     0x00000015 
     nsCSSFrameConstructor::AttributeChanged() 
     StyleSetImpl::AttributeChanged() 
     PresShell::AttributeChanged() 
     nsDocument::AttributeChanged() 
     nsGenericHTMLElement::SetAttribute() 
     nsHTMLImageElement::SetSrcInner() 
     nsHTMLImageElement::SetProperty() 
     nsJSUtils::nsCallJSScriptObjectSetProperty() 
     SetHTMLImageElementProperty() 
     js_SetProperty() 
     js_Interpret() 
     js_Execute() 
     obj_eval() 
     js_Invoke() 
     js_Interpret() 
     js_Invoke() 
     js_Interpret() 
     js_Execute() 
     JS_EvaluateUCScriptForPrincipals() 
     nsJSContext::EvaluateString() 
     HTMLContentSink::EvaluateScript() 
     HTMLContentSink::OnStreamComplete() 
     nsStreamLoader::OnStopRequest() 
     InterceptStreamListener::OnStopRequest() 
     nsHTTPChannel::ResponseCompleted() 
     nsHTTPResponseListener::OnStopRequest() 
     nsOnStopRequestEvent::HandleEvent() 
     nsStreamListenerEvent::HandlePLEvent() 
     PL_HandleEvent() 
     PL_ProcessPendingEvents() 
     nsEventQueueImpl::ProcessPendingEvents() 
     event_processor_callback() 
     our_gdk_io_invoke() 
     libglib-1.2.so.0 + 0xe52a (0x406a752a) 
     libglib-1.2.so.0 + 0xfbe6 (0x406a8be6) 
     libglib-1.2.so.0 + 0x101a1 (0x406a91a1) 
     libglib-1.2.so.0 + 0x10341 (0x406a9341) 
     libgtk-1.2.so.0 + 0x8c209 (0x405d0209) 
     nsAppShell::Run() 
     nsAppShellService::Run() 
     main1() 
     main() 
     libc.so.6 + 0x181eb (0x4021f1eb) 

I tested this in 2000021408 Linux build.  This does not happen 2000021111 Linux build and 2000021408 Win32 build.
(Reporter)

Updated

19 years ago
QA Contact: paulmac → teruko
Summary: Crash at loading this page → Crash at loading this page

Comment 1

19 years ago
Could not reproduce crash on Linux build 2000.02.14.09.  However, site uses
unsupported  <layer> and document.layer; sent email to zdnet@softbank.co.at
using http://sites.netscape.net/ekrock/fixit/layer.html and
http://sites.netscape.net/ekrock/fixit/useragent.html.

Comment 2

19 years ago
layout bug
Assignee: hyatt → rickg

Comment 3

19 years ago
Pierre -- given the stack trace -- I'm forwarding this to you.
Assignee: rickg → pierre

Updated

19 years ago
Severity: major → critical
Keywords: crash
(Reporter)

Comment 4

19 years ago
This does not happen in 2000021708 and 2000021808 Linux build.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

19 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.