Subscribing to discussion.epoc.C++ newsgroup crashes mozilla [@ nsMsgKeySet::Output]

RESOLVED DUPLICATE of bug 188243

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED DUPLICATE of bug 188243
13 years ago
6 years ago

People

(Reporter: Ric, Assigned: Bienvenu)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
When I try to suscribe to discussion.epoc.C++ at the above link mozilla 1.7.5
chrashes I tried this both under freebsd and windows xp.

If I use thunderbird everything is fine.

Updated

13 years ago
Severity: major → critical
Keywords: crash

Comment 1

13 years ago
Stacktrace (with a current trunk build):
nsMsgKeySet::Output(nsMsgKeySet * const 0x00000000, char * * 0x0012f99c) line 316
nsMsgNewsFolder::UpdateSummaryFromNNTPInfo(nsMsgNewsFolder * const 0x00000000,
int 0x00000002, int 0x00008eb9, int 0x000076b0) line 797 + 24 bytes
nsNNTPProtocol::BeginReadXover(nsNNTPProtocol * const 0x00000000) line 3350
nsNNTPProtocol::ProcessProtocolState(nsNNTPProtocol * const 0x00000000, nsIURI *
0x017550f9, nsIInputStream * 0x02dd0474, unsigned int 0x01b2ebe0, unsigned int
0x00000088) line 5061
nsMsgProtocol::OnDataAvailable(nsMsgProtocol * const 0x00000009, nsIRequest *
0x0253f118, nsISupports * 0x00000000, nsIInputStream * 0x00000000, unsigned int
0x00000000, unsigned int 0x00000000) line 325 + 20 bytes
MSGNEWS! const  nsNntpUrl::`vftable'{for `nsMsgMailNewsUrl'} address 0x03a4a210
nsNntpUrl::AddRef(nsNntpUrl * const 0x03a47f9c nsMsgMailNewsUrl::GetSpec) line 84
nsNntpUrl::Release() address 0x03a3524e
UCONV! g_uf0208Mapping + 20624 bytes

Crashes in line:
	size = m_length;

|this| is 0x00000000. 
Summary: Subscribing to discussion.epoc.C++ newsgroup crashes mozilla → Subscribing to discussion.epoc.C++ newsgroup crashes mozilla [@ nsMsgKeySet::Output]
Version: 1.7 Branch → Trunk

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
over to david, cc neil.

note, he says tbird is fine.
Assignee: sspitzer → bienvenu

Comment 4

13 years ago
OK, so what's happening here is that nsNNTPProtocol::LoadUrl is calling
nsNntpIncomingServer::SubscribeToNewsgroup("discussion.epoc.C%2B%2B"); which is
calling nsMsgNewsFolder::CreateSubfolder which is calling
nsMsgNewsFolder::AddNewsgroup("discussion.epoc.C++", ...); - oops.

Of course when nsNNTPProtocol::LoadUrl later calls
nsNntpIncomingServer::FindGroup("discussion.epoc.C%2B%2B") it won't find it.

I tried bypassing the call to NS_MsgDecodeUnescapeURLPath in
nsNntpIncomingServer::SubscribeToNewsgroup but it still faulted :-(
<http://www.symbian.com/developer/public/index.html>
does not seem to have any News/NNTP link (anymore).

***

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.13) Gecko/20060414] (release) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1pre) Gecko/2008062515 SeaMonkey/2.0a1pre] (SEA-WIN32-TBOX-trunk) (W2Ksp4)

From Browser location bar (or MailNews UI),
subscribing to <news://news.free.fr:119/comp.lang.c++> works fine.

WorksForMe, or is it not the proper way to test this ?

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 188243

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: search
Crash Signature: [@ nsMsgKeySet::Output]
You need to log in before you can comment on or make changes to this bug.