unicode characters are not printed correctly

RESOLVED EXPIRED

Status

()

Core
Printing: Output
RESOLVED EXPIRED
13 years ago
12 years ago

People

(Reporter: Vern Poythress, Unassigned)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Firefox 1.0 running on linux fc2 prints squares and blanks instead of Hebrew and
Extended Greek Unicode, whether printing is to Epson 860 or Savin (HP laserjet
4P compatible).  On-screen display of the page is OK; print preview shows
unicode characters, but with odd extra space following.  Firefox 1.0 on Windows
2K prints correctly.  OpenOffice 1.1.4 and 1.9.65 print the file correctly on
linux fc2 (and I presume on Windows 2K).  If needed, I can send you the sample
html and the (free) unicode fonts that I am using.

vpoythress1@netscape.net

Comment 1

13 years ago
Vern,

Could you provide the following?

1) A sample page (URL) containing the kind of text you're talking about. This
should go in the "URL" field above.

2) The output of printing that page to a file. Please attach this using the
"create a new attachment" link above.

3) The name of the printer you're printing to, as displayed in mozilla's print
dialog?
Component: General → Printing
Product: Firefox → Core
(Reporter)

Comment 2

13 years ago
Created attachment 170374 [details]
It is the result of telling firefox to print html text to a file.
(Reporter)

Comment 3

13 years ago
When I print to the printer, I choose either "Postscript/Epson860" or
"Postscript/Savin" in the printer box.

Updated

13 years ago
Assignee: firefox → core.printing
QA Contact: firefox.general
Vern, did you mean to put a URL in the URL field?  It looks like you put a
doctype there instead...

Clearing URL field, since it doesn't contain a URL.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.