Wrap text for non HTML emails not working at all

RESOLVED DUPLICATE of bug 277153

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 277153
14 years ago
14 years ago

People

(Reporter: sturges, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6)
Gecko/20041210 and prior versions.

As reported in associated bugs 155622 and 274168 there are problems with the
wrap text.

I have discovered that Mozilla lies about the formatting of the emails that are
composed using the Html editor and sent as "Send as Plain Text Only
(Recommended)", this is why I submit a new bug.

What actually happens is Mozilla inserts line breaks after about 72 characters
in the outgoing email regardless of any settings [see tests below]. 

When previewing the sent emails, or opening them, Mozilla pretends it hasn't
inserted these line breaks but if you do a CTL+U you get the real story.

After composing an email with the desired line breaks in the correct places
Mozilla inserts so many line breaks that it makes a nonsense of reading the text
at the other end.

Even Netscape 4.7x did not have this problem.


Tests performed:
From an email composition window do Edit | Preferences | Mail & Newsgroups |
Composition;
Using the setting "Wrap plain test messages at 0 characters" and "Wrap plain
test messages at 1000 characters" - the result is the same.


Bugs:

1) Mozilla inserts uncontrollable line breaks in outgoing emails.
2) Mozilla renders emails differently from what is actually received or sent.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 277153 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.