Split the screen into multiple panes - Multi-pane UI and GUI

RESOLVED DUPLICATE of bug 231156

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 231156
13 years ago
13 years ago

People

(Reporter: boris, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
The larger the screens get, the more space is unused in the browser window,
specially on wide screens.
So maye it would be good to have an option to split the visible region of the
browser into multiple colums and have the content flowing through all the
columns. The sliders would work like before (only one pair of x-y sliders for
all the columns).
This will might improve the situation until CSS3-multi-column layout will land
(Bug 251162) and could go well together with multi tab display (Bug 70245) or
the independent view of one large document (Bug 111891), the latter is actually
the decoupled version of the current suggestion.
An UI that supports a view ->split horizontally / vertically (displays like a
"double/multiple-tab" - a single tab with a separator-line in between, seperate
sliders for each pane, active pane/tab marked in color)
and an option
"view ->link panes" (display linking dependent on the writing direction,
depicted by a chain symbol between the linked tabs, only one slider-pair) would
complete the enhancement.

Comment 1

13 years ago
this was already rejected in bug 231156
(Reporter)

Comment 2

13 years ago
Created attachment 170441 [details]
MultiPane Interface

Interface suggestion for multiple pane interface

*** This bug has been marked as a duplicate of 231156 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> 
> *** This bug has been marked as a duplicate of 231156 ***

I agree that bug #231156 has parts of this bugs included - however this bug
purposes a structure to combine the resolutions of the bugs mentioned above in
an interface and thus superseeds them.
You need to log in before you can comment on or make changes to this bug.