Relative applet height sizing is not correct

RESOLVED DUPLICATE of bug 211530

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 211530
14 years ago
14 years ago

People

(Reporter: Ching Wan, Unassigned)

Tracking

Other Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
If an applet uses relative sizing, such as <APPLET WIDTH="90%" HEIGHT="90%"
...>, the computed applet size is OK for width, but the height is way too small
than the relative window size, and it almost looks like it is fixed at 200 px or so.

This is a bug in Mozilla and Firefox.  The applet with relative sizing displays
correctly in IE and Netscape browsers.

Comment 1

14 years ago
> If an applet uses relative sizing, such as <APPLET WIDTH="90%" HEIGHT="90%"
> ...>, the computed applet size is OK for width, but the height is way too small
> than the relative window size

Height percentage value is relative to its block-level element: "The value may
be given in pixels or as a percentage of the parent element's width or height."
http://www.htmlhelp.org/reference/html40/special/applet.html

See also bug 211530 and
https://bugzilla.mozilla.org/show_bug.cgi?id=211530#c10

Ching, you have not provided an URL or a testcase showing the layout problem.
Best is to provide a reduced testcase.

(Reporter)

Comment 2

14 years ago
Here is how to reproduce the bug:

http://qwan-home.pivotlink.com/applet1.html

Make sure to "enable Java" in Mozilla or Firefox to view the applet box.  The
height of the applet box is wrong when the header contains the <!DOCTYPE html
... text generated by the CGI.pm Perl module.  Netscape seems to have the same
problem.

To view the same page without the <!DOCTYPE html .. header, see URL:

http://qwan-home.pivotlink.com/applet2.html

In this page, the applet box is sized correctly.  Both pages are displayed
correctly in IE.

Comment 3

14 years ago
Pretty much everything explained in comments #10, #11 and #12 in bug 211530
explains, covers the layout issues and your points here.

I'm using the latest JRE 1.5.0_01.

In http://qwan-home.pivotlink.com/applet1.html (Standards mode), the rendered
height of the applet is 200px (not 240px). I suppose this is the default height
value for default height value in cases of unspecified height value for this
class of specific cases in Mozilla. Mozilla 1.8a6 build 2005010606 under XP Pro
SP2 here. In MSIE 6 SV1, the rendered height of the applet is precisely 90% of
the body height which is proportionally related to the height of the viewport:
resizing the MSIE 6 browser window height resizes the height of the rendered
applet viewport. Again, comment #10 explains.

In http://qwan-home.pivotlink.com/applet2.html (Quirks mode), the rendered
height of the applet is precisely 90% of the body height which is proportionally
related to the height of the viewport in all browsers (MSIE 6 SV1, Mozilla 1.8a6
and Firefox 1.0 rv: 1.7.5 build 20041107). Again, comment #10 explains.

Rendering mode is shown: View/Page Info/General tab/Render mode


*** This bug has been marked as a duplicate of 211530 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.