BZ forgetting login (may be cookie related)

RESOLVED DUPLICATE of bug 179770

Status

()

RESOLVED DUPLICATE of bug 179770
14 years ago
6 years ago

People

(Reporter: kbenton, Assigned: myk)

Tracking

2.19.1
x86
Windows XP

Details

(Reporter)

Description

14 years ago
I am running into a problem with BZ where it's forgetting my login.  In some
cases, I have to log in multiple times.  This is occuring with BZ 2.19.1+ on
BMO, and a number of installations from 2.17.3 custom to 2.17.4 converted to
2.19.1 custom installations.  I am running Firefox 1.0, and others in-company
are reporting the same issue with a number of other browsers including IE,
Netscape, Mozilla, and Firefox.
(Reporter)

Comment 1

14 years ago
Quick FYI - again this is happening at http://bugzilla.mozilla.org/ as well.  I
have deleted cookies, made sure my browser is upgraded, and I am certain that my
IP is not changing.
(Reporter)

Comment 2

14 years ago
Part of the problem I'm seeing involves rolling IP's.  While I can reproduce
this issue with or without rolling IP's, part of what I see as a fundamental
issue is that users (like myself) are not able to edit their preferences to make
their login session cookie a session rather than an IP-based non-limited deal. 
So, for example, if I know I'm going to have to log in through a firewall that
changes my IP as presented to the web server, then I know I'm going to have
issues with staying logged in.  On the other hand, if I had an option to check a
box that allowed me to use a time-limited session instead of an unlimited
session based on IP, then we could maintain security without nearly the level of
difficulty imposed on people who can not get around the rolling-IP issue.

Comment 3

14 years ago
Okay, I knew I'd seen this somewhere before... and so did Frederic (LpSolit). 
He wondered if this was a dupe of bug 179770, and I agreed that it probably is.

Reading that one turned up a pointer to bug 179192, which contains some info 
that might help you actually fix the problem -- locally, at least -- if your 
IPs are close enough together.

There's also a pointer (in one of those two bugs) to bug 20122, which seems to 
be the exact issue that you've raised here. Might be worth looking at the 
discussion to see what's been said before.

Anyway, this is almost certainly a duplicate of *something*; I'd suggest 
179770. Dave just now gave you editbugs privs on bmo, so you can RESOLVE this 
one as a DUPLICATE yourself of whatever one you think is most appropriate.

(I notice that nobody's working on that one, and there are no patches uploaded. 
You wanna grab it for yourself? :)
(Reporter)

Comment 4

14 years ago
Thanks for helping me find the dupe, guys.

*** This bug has been marked as a duplicate of 179770 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.