"Entire message" search in Thunderbird doesn't work for emails

RESOLVED DUPLICATE of bug 67421

Status

defect
RESOLVED DUPLICATE of bug 67421
15 years ago
14 years ago

People

(Reporter: figelwump, Assigned: mscott)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
When using "Entire Message" option in search pulldown, Thunderbird returns all
messages.  Given search terms are ignored.  Searching by "subject" or "sender"
is fine.

Comment 1

15 years ago
It does not work for me on an NNTP server. It works fine on an IMAP server or in
local folders.

Comment 2

15 years ago
NNTP doesn't support body search, so there's not much we can do (other than
disabling that option for newsgroups) or searching the offline store, if you
have the newsgroup configured for offline use.

Comment 3

15 years ago
Hmmmmm. Pine seems to do it. Is it just downloading every message and searching
locally? It takes long enough that that is what I have always suspected.

Comment 4

15 years ago
that's another option, but what happens if you have a 10,000 message newsgroup?
There was an NNTP extension that allowed search of message bodies, but afaik,
the Netscape news server was the only one that implemented it, so it never went
anywhere.
Summary: "Entire message" search in Thunderbird is broken → "Entire message" search in Thunderbird doesn't work for news

Comment 5

15 years ago
Well, a quick test indicates that Pine seems to deal with a text search in a
2600-message newsgroup off a server on the LAN fine. It did take about 30
seconds for the search though.

I understand the reasons why this feature is not implemented, but it is in other
newsreaders and I feel that it would be useful here as well. The presence of a
non-working "Entire Message" option is a bug, even if you don't want to
implement the functionality.
Reporter

Comment 6

15 years ago
Actually it does not work for me when searching messages on an IMAP server,
which was what the bug was originally about.  Any ideas regarding that issue?

Thanks

Comment 7

15 years ago
It WORKSFORME on IMAP. Perhaps your server does not support search? Try using
some other IMAP client that supports search on the same server and see if it works.
Reporter

Comment 8

15 years ago
It works when using Microsoft Outlook Express as my imap client...

Comment 9

15 years ago

*** This bug has been marked as a duplicate of 83971 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 10

15 years ago
I think I have unintentionally hijacked this bug which has now resulted in it
being declared a duplicate. The original reporter didn't say it was an IMAP
problem originally but eventually clarified in comment #6.

OTOH, regarding the complaint of the original reporter, it WORKSFORME.
Reporter

Comment 11

15 years ago
Reopening as the problem I am facing is not a duplicate of bug 83971.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Reporter

Updated

15 years ago
Summary: "Entire message" search in Thunderbird doesn't work for news → "Entire message" search in Thunderbird doesn't work for emails

Comment 12

15 years ago
removing CC
Duping to the correct bug.

*** This bug has been marked as a duplicate of 67421 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
Reporter

Comment 14

14 years ago
Not sure how much 67421 is a duplicate of this bug.  It looks like 67421 is
about filters, whereas this bug is about search.  I don't know about how
thunderbird is implemented, maybe the root cause of both problems is the same. 
Just want to be clear about the difference...
You need to log in before you can comment on or make changes to this bug.