Status

NSPR
NSPR
RESOLVED DUPLICATE of bug 418686
14 years ago
11 years ago

People

(Reporter: David Gardiner, Assigned: dougt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
I think this needs to be done in order to port Mozilla to WinCE.

Any pointers as to how to best do this is appreciated, otherwise I'll just
stumble along and try to get it there myself :-)

-dave
(Reporter)

Updated

14 years ago
Blocks: 277211

Comment 1

14 years ago
This is already done.  It's just that I haven't
reviewed and merged the patch yet.  The patch
currently lives on a CVS branch and may be slightly
out of date (with respect to the tip of the source
tree) now.
(Reporter)

Comment 2

14 years ago
Looks like this is tagged as WINCE_20020710_BRANCH (?)

I'll see if I can get it working.

(I did a search, but can't find any bug related to that branch so i guess this
one will do)

-dave
(Reporter)

Comment 3

14 years ago
I've got as far as this:

sh ../../../build/cygwin-wrapper cl -Foprfdcach.obj -c     -W3 -nologo -GF -Gy -
Zl -GR- -GX- -Gi- -Gm- -Od -Zi   -UNDEBUG  -DDEBUG=1 -DDEBUG_gardindr=1 -DXP_PC=
1 -DWIN32=1 -D_DEBUG=1 -DWINCE=1 -D_PR_GLOBAL_THREADS_ONLY=1 -DUNICODE=1 -D_UNIC
ODE=1 -D_WIN32_WCE=400 -DUNDER_CE=400 -D_X86_=1 -Dx86=1 -D_WIN32_WCE_CEPC=1  -DF
ORCE_PR_LOG -D_NSPR_BUILD_ -I../../../dist/include/nspr -I../../../pr/include -I
../../../pr/include/private -I../../../dist/include  prfdcach.c
prfdcach.c
../../../dist/include/nspr\prcpucfg.h(57) : fatal error C1083: Cannot open inclu
de file: 'moz_shunt_ppc2002.h': No such file or directory
make[3]: *** [prfdcach.obj] Error 2

Anyone know where (or what) moz_shunt_ppc2002.h might be?

-dave
(Assignee)

Comment 4

14 years ago
That file is part of a early attempt to port mozilla.  The shunt that was
recreated was incompete.  I have changes in my local tree that I will be seeking
review for.
Assignee: wtchang → dougt
(Reporter)

Comment 5

14 years ago
Cool.. I'd be interested in having a look at the changes if you could post up a
patch sometime.

thanks,
-dave
(Assignee)

Comment 6

14 years ago
Created attachment 170883 [details] [diff] [review]
Patch v.1

This is a cleaned up patch from Nelson's and Garrent's branch.	Most of this
patch is only changes when building WINCE.

To build this still requires a shim layer (a piece of code that provides
functionality that win32 provices that wince doesn't).	So, you can't build
WINCE NSPR out of box, but I don't think anyone was intending this to be the
case.  

Wan-Teh, can you take a look?
Attachment #170883 - Flags: review?(wtchang)
(Reporter)

Comment 7

14 years ago
I presume that you run ./configure --host=xxxxx

What do you use for 'xxxxx' ?

-dave
(Reporter)

Comment 8

14 years ago
And also which WinCE compiler/SDK did you use?

-dave
(Assignee)

Comment 9

14 years ago
using eMbedded Visual C++ 4.0 SP2.  I am runing the build through a modified
mozconfig file.  The basic settings were:


OS_TARGET=WINCE
mk_add_options OS_TARGET=WINCE
ac_add_options --target=arm-wince
ac_add_options --enable-win32-target=win95
ac_add_options --enable-default-toolkit=windows

Comment 10

14 years ago
Doug, your OS_TARGET=WINCE setting conflicts with
the --enable-win32-target=win95 configure option
(which sets OS_TARGET=WIN95).
(Assignee)

Comment 11

14 years ago
i will try setting both to wince.  I have been compiling without a problem
setting -enable-win32-target=win95.  thanks.
(Assignee)

Comment 12

14 years ago
or rather, I will play around with the options for a bit.  it might be possible
to remove these lines:

OS_TARGET=WINCE
mk_add_options OS_TARGET=WINCE

and simply use

ac_add_options --enable-win32-target=win95
(Reporter)

Comment 13

14 years ago
Doug,
as you mentioned mozconfig, are you starting this all off by doing a make
client.mk in the root of mozilla, or are you just running ./configure inside
nsprpub?

-dave
(Assignee)

Comment 14

14 years ago
yes, that is correct.  I am doing mozilla top level builds.
(Assignee)

Comment 15

14 years ago
Comment on attachment 170883 [details] [diff] [review]
Patch v.1

wtchang, I will attach a better patch.	this patch has some issues.
Attachment #170883 - Flags: review?(wtchang) → review-
(Assignee)

Comment 16

14 years ago
Created attachment 172732 [details] [diff] [review]
patch v.2

wtc, can you look over this patch.
Attachment #170883 - Attachment is obsolete: true
Attachment #172732 - Flags: review?(wtchang)
(Assignee)

Comment 17

13 years ago
Comment on attachment 172732 [details] [diff] [review]
patch v.2

clearing old request flag
Attachment #172732 - Flags: review?(wtchang)
QA Contact: wtchang → nspr
(Assignee)

Comment 18

11 years ago
marking this as a dup.  new patch new love in: 418686    
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 418686
You need to log in before you can comment on or make changes to this bug.