Failed DNS lookup on URL hangs browser and all tabs

RESOLVED DUPLICATE of bug 188332

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 188332
14 years ago
13 years ago

People

(Reporter: LaPlaine, Assigned: Blake Ross)

Tracking

({hang})

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Simply enter an URL that will fail DNS lookup and it hangs the browser for all
tabs. Easily repeatable for me. Only solution is to kill firefox process and
restart.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20050107
Firefox/1.0+

WFM

I simply get an errordialog

type
 about:config in the locationbar
type
 browser.xul.error_pages.enabled in the input of the about:config screen
doubleclick on it to set the value from false to true.
close that tab

type an url that does not exist

Updated

14 years ago
Keywords: hang
(Reporter)

Comment 2

14 years ago
Thanks Peter, but the change didn't make a difference. Still locks of the
firefox process.

Comment 3

13 years ago
Do you have an Automatic proxy configuration URL? If so, what happens when you
specify the proxy settings manually?

seealso: http://forums.mozillazine.org/viewtopic.php?t=222079
(Reporter)

Comment 4

13 years ago
No proxy is involved. I am directly connected to the Internet, and the selection
is checked for that in the Options. I wish this problem got some more attention,
as even a miss-typed URL will lock up the process forcing a kill to use firefox
again.

Comment 5

13 years ago
I had no problems with 1.0, but after upgrading to 1.0.1, the browser fails to 
load any URLs.  The load indicator bar at the bottom of the browser gets to the 
half way point and just stops.  The load comment on the lower left 
says, "Looking up www.(whatever the web site is, including my default, Google)"
I have tried uninstalling and reinstalling, but only got it to uninstall once.  
Now when I try to uninstall, it notes that it cannot be uninstalled since it is 
running, and the uninstall software (included with XP Home) cannot shut it 
down.  The Windows Task Manger also shows Firefox.exe running, but the "End 
Process" button in WTM will not shut it down.  In short, can't get it to work, 
can't uninstall it.

Comment 6

13 years ago
I had no problems with 1.0, but after upgrading to 1.0.1, the browser fails to 
load any URLs.  The load indicator bar at the bottom of the browser gets to the 
half way point and just stops.  The load comment on the lower left 
says, "Looking up www.(whatever the web site is, including my default, Google)"
I have tried uninstalling and reinstalling, but only got it to uninstall once.  
Now when I try to uninstall, it notes that it cannot be uninstalled since it is 
running, and the uninstall software (included with XP Home) cannot shut it 
down.  The Windows Task Manger also shows Firefox.exe running, but the "End 
Process" button in WTM will not shut it down.  In short, can't get it to work, 
can't uninstall it.

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

13 years ago

*** This bug has been marked as a duplicate of 188332 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.