If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

pb.com - doesn't recognize Firefox as 128-bit, can't checkout cart

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
13 years ago
3 years ago

People

(Reporter: Scott I. Remick, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

You can shop around on www.pb.com and add stuff to your cart. But as soon as you
go to checkout, you get the error on the URL listed above. It begins:

"For your protection, Pitney Bowes requires that 128-bit browser encryption be
used for all transactions occurring in our online store. We also highly
recommend the use of Microsoft Internet Explorer for all transactions."

This is strange because it suggests that any browser with 128-bit encryption
would work and that IE is only "recommended", but this is not the case.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.pb.com/
2. Click on Online Store
3. Add anything to your cart
4. Click [Proceed to Checkout] button.

Actual Results:  
Get this page:
http://www.pb.com/cgi-bin/pb.dll/jsp/supplies/shopcart/pbrs128bitencryption.jsp

For your protection, Pitney Bowes requires that 128-bit browser encryption be
used for all transactions occurring in our online store. We also highly
recommend the use of Microsoft Internet Explorer for all transactions.

If you are viewing this page, we have detected that your browser does not
support 128-bit encryption. To easily upgrade your browser, please take one of
the following courses of action:

Your best option is to upgrade to the latest version of Internet Explorer.
You can accomplish this by visiting the Internet Explorer homepage on
Microsoft's site:
http://www.microsoft.com/windows/ie/default.asp
If you have Internet Explorer version 5.01 or earlier, you can also upgrade to
128-bit encryption by visiting the following link and downloading the file
appropriate for your operating system:

http://www.microsoft.com/windows/ie/downloads/recommended/128bit/default.asp
Once you have finished installation, please return to our store homepage at
http://www.pb.com/supplies and re-enter your desired purchases. Once you reach
our checkout process you will be able to move through smoothly and securely.We
apologize for any inconvenience and sincerely thank you for your business.

Expected Results:  
Should be able to checkout just fine, since Firefox has 128-bit encryption.

Comment 1

13 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new

Reporter, when you file a TE bug, please follow the reporting guidelines.
Summary: Pitney Bowes doesn't recognize Firefox as 128-bit, can't checkout cart → pb.com - doesn't recognize Firefox as 128-bit, can't checkout cart
(Reporter)

Comment 2

13 years ago
Got the following response from PB:

"The Pitney Bowes websites are engineered to work with the latest versions of
Internet Explorer and it is not recommended to use any other type of browser.
Pitney Bowes has no plans to change the design of our sites to allow other
browser access. This is due to the fact that, statistically speaking, only about
five percent of our customers, worldwide, utilize any other brothers. I
apologize for any inconvenience. If you have any further questions please let me
know. Sincerely, Carla, Pitney Bowes Online Support Team"

Comment 3

10 years ago
I don't have an account there, but I was able to add things to my account and click the checkout button (which sent me to the account signup page) without any problems. Sounds FIXED to me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.