listbox removeItemAt also removes column headings.

RESOLVED DUPLICATE of bug 236068

Status

()

RESOLVED DUPLICATE of bug 236068
14 years ago
14 years ago

People

(Reporter: pwilson, Assigned: jag-mozilla)

Tracking

1.7 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
This operation should only remove listitem elements and should preserve listhead
and listcols elements.
The listbox XBL binding code says it all:
      <method name="removeItemAt">
        <parameter name="index"/>
        <body>
        <![CDATA[
          var remove = this.childNodes[index];
          if (remove)
            this.removeChild(remove);
          return remove;
        ]]>
        </body>
      </method>
Bugs with XUL are the product Core, components like XBL and the various XP
Toolkit components (unless you know for sure that Firefox forked a particular
bit). Please pick an appropriate place to file there, and save us all one extra
set of bugspam.
Assignee: firefox → jag
Component: General → XP Toolkit/Widgets
Product: Firefox → Core
QA Contact: general → jrgmorrison
Version: 1.0 Branch → 1.7 Branch

Comment 2

14 years ago
This has been fixed in bug 236068, hasn't it?
Indeed.  Phil, firefox has forked _all_ the XBL bindings for XUL.  So any bug
reported against the non-C++ part of XUL needs to be fixed separately for
Firefox and Mozilla...

*** This bug has been marked as a duplicate of 236068 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.