<Input typ=file> has big rendering problems

RESOLVED DUPLICATE of bug 132565

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 132565
13 years ago
13 years ago

People

(Reporter: Egon Knapen, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

prefered is a inputbox with a button browse next to it and an other button
upload. The background of the browse button is the same as the background of the
input-box instead of the background of the page in which it is.

Further by using style="width:10px;" it is possible to remove the white
background behind the 'browse' button, but the extra 'upload' button gets
positioned wrong when I use it.

Even when the <input type=file> is used within a table, the file-component
is rendered way outside its table-cell.

Reproducible: Always

Steps to Reproduce:
1. insert an <input type=file>
2. but a button behind it <input type=button>
3. try to use size=55 or style="width:500px;" on the first input-box

Actual Results:  
the browse button has the wrong background

the upload button is not behind the browse button

both buttons are positioned wrong.

Expected Results:  
I would expect an input-box, with next to it an 'browse' button, without an
white background color, next to it should be the upload button.

I create a page on http://www.falun-world.com/mozilla-test.htm, with various
scenarios,  where the first 8 points are rendering wrong.

I know how to work around it, but I just think it is cosmetic error that should
be fixed.

MSIE has the problem that it uses the wrong button-style, but the rest of its
rendering is better in this case.
(Reporter)

Comment 1

13 years ago
sorry summary was in german...
Summary: <Input typ=file> had ziemliche render problemen. → <Input typ=file> has big rendering problems

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 132565 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.