Fails to break lines for characters in Latin-1 range

RESOLVED DUPLICATE of bug 255990

Status

()

Core
Internationalization
--
major
RESOLVED DUPLICATE of bug 255990
13 years ago
13 years ago

People

(Reporter: ryo, Assigned: Blake Ross)

Tracking

({intl})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Hi, I just found it out today accidentally.

I have been developing multiligual site (EN, Japanese and Estonian) mostly 
using PHP.

However, this one simple page is just a basically html text page with 
description of the site in these three languages one after another. Page is 
something like this below. Small php script within head tag is a language 
encoding switch by cookie according to user's choice.

However, I am aware that viewers of this post do not have this cookie being 
planted, therefore I have provided both in Western and Japanese plain html 
coding below for your testing purpose and the result will be the same.

If you run either <Western.html> or <Japanese.html> on IE or NS browsers, both 
pages will nicely wraped around according to the table width being defined by 
table tag, no problem, 85% of the given screen width.

Now, if you try the same with Firefox, some mess happens. in <Western.html>, 
the table width defined by table tag is completely ignored and the texts would 
not wrap around according to the table width!!

In <Japanese.html> , it works, since Japanese encoding is outpitting Western 
Characters as mbstring and both Western Characters and Japanese Characters 
renders the same encoding method using mbstring.

So, the question is that how am I supposed to deal with this mess by Firefox? 
Am I missing something? Of course I can iframe Japanese portion as separated 
html with different encoding to concour this problem to make this page works as 
cross browser page.

Well, anyone has clue to resolve this problem for me?

Thanks million in advance.

Ryo

Sample pages : 1. sample.php 2. Western.html 3. Japanese.html

-- 1. sample.php --

<!doctype html public "-//W3C//DTD HTML 
4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html><head>
<?php
$n=$_COOKIE["LangCookie"];
if($n==jp)
{
echo "<META name=content-language content=ja><meta http-equiv=Content-Type 
content=\"text/html; charset=Shift_jis\">";
}
else
{echo "<meta http-equiv=\"Content-Type\" content=\"text/html; charset=ISO-8859-1
\">";
}
?>
</head><body>
<table width=85%><tr><td>
English Description of the page : 
abcdefghisjklmnopqrstuvwxyz,abcdefghisjklmnopqrstuvwxyz,
abcdefghisjklmnopqrstuvwxyz, abcdefghisjklmnopqrstuvwxyz, 
abcdefghisjklmnopqrstuvwxyz, etc.<p>

Estonian Description of the page : a b d e g h i j k l m n o p r s t u v õ ä ö 
ü,a b d e g h i j k l m n o p r s t u v õ ä ö ü,a b d e g h i j k l m n o p r s 
t u v õ ä ö ü,a b d e g h i j k l m n o p r s t u v õ ä ö ü,etc<p>

Japanese Description of the page : ˆ¤ƒEƒG‚¨‘‚«‚­‚¯”Z‚³Ž€‚·”w‘c‚½‚¿‚‚ĂƉ
½‚ʍª‚͔̂畆‚Ö•ä^”ü–
³ƒƒ‚‚â‚¢‚ä‚¢‚¥‚æ‚ç‚è‚é‚ê˜I˜aŒ¾‚¤ƒEƒF‚ðƒAƒCƒEƒGƒIƒJƒLƒNƒPƒRƒTƒVƒXƒZƒ\ƒ^ƒ`ƒcƒeƒgƒ
iƒjƒkƒlƒmƒnƒqƒtƒwƒzƒ}ƒ~ƒ€ƒƒ‚ƒ„ƒCƒ†ƒGƒˆƒ‰ƒŠƒ‹ƒŒƒƒƒCƒEƒEƒFƒ’ƒ“
,ˆ¤ƒEƒG‚¨‘‚«‚­‚¯”Z‚³Ž€‚·”w‘c‚½‚¿‚‚ĂƉ½‚ʍª‚͔̂畆‚Ö•ä^”ü–
³ƒƒ‚‚â‚¢‚ä‚¢‚¥‚æ‚ç‚è‚é‚ê˜I˜aŒ¾‚¤ƒEƒF‚ðƒAƒCƒEƒGƒIƒJƒLƒNƒPƒRƒTƒVƒXƒZƒ\ƒ^ƒ`ƒcƒeƒgƒ
iƒjƒkƒlƒmƒnƒqƒtƒwƒzƒ}ƒ~ƒ€ƒƒ‚ƒ„ƒCƒ†ƒGƒˆƒ‰ƒŠƒ‹ƒŒƒƒƒCƒEƒEƒFƒ’ƒ“
,ˆ¤ƒEƒG‚¨‘‚«‚­‚¯”Z‚³Ž€‚·”w‘c‚½‚¿‚‚ĂƉ½‚ʍª‚͔̂畆‚Ö•ä^”ü–
³ƒƒ‚‚â‚¢‚ä‚¢‚¥‚æ‚ç‚è‚é‚ê˜I˜aŒ¾‚¤ƒEƒF‚ðƒAƒCƒEƒGƒIƒJƒLƒNƒPƒRƒTƒVƒXƒZƒ\ƒ^ƒ`ƒcƒeƒgƒ
iƒjƒkƒlƒmƒnƒqƒtƒwƒzƒ}ƒ~ƒ€ƒƒ‚ƒ„ƒCƒ†ƒGƒˆƒ‰ƒŠƒ‹ƒŒƒƒƒCƒEƒEƒFƒ’ƒ“

</td></tr></table>
</body></html>




--2.Western.html---

<!doctype html public "-//W3C//DTD HTML 
4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html><head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
</head><body>
<table width=85%><tr><td>
English Description of the page : 
abcdefghisjklmnopqrstuvwxyz,abcdefghisjklmnopqrstuvwxyz,
abcdefghisjklmnopqrstuvwxyz, abcdefghisjklmnopqrstuvwxyz, 
abcdefghisjklmnopqrstuvwxyz, etc.<p>

Estonian Description of the page : a b d e g h i j k l m n o p r s t u v õ ä ö 
ü,a b d e g h i j k l m n o p r s t u v õ ä ö ü,a b d e g h i j k l m n o p r s 
t u v õ ä ö ü,a b d e g h i j k l m n o p r s t u v õ ä ö ü,etc<p>

Japanese Description of the page : ˆ¤ƒEƒG‚¨‘‚«‚­‚¯”Z‚³Ž€‚·”w‘c‚½‚¿‚‚ĂƉ
½‚ʍª‚͔̂畆‚Ö•ä^”ü–
³ƒƒ‚‚â‚¢‚ä‚¢‚¥‚æ‚ç‚è‚é‚ê˜I˜aŒ¾‚¤ƒEƒF‚ðƒAƒCƒEƒGƒIƒJƒLƒNƒPƒRƒTƒVƒXƒZƒ\ƒ^ƒ`ƒcƒeƒgƒ
iƒjƒkƒlƒmƒnƒqƒtƒwƒzƒ}ƒ~ƒ€ƒƒ‚ƒ„ƒCƒ†ƒGƒˆƒ‰ƒŠƒ‹ƒŒƒƒƒCƒEƒEƒFƒ’ƒ“
,ˆ¤ƒEƒG‚¨‘‚«‚­‚¯”Z‚³Ž€‚·”w‘c‚½‚¿‚‚ĂƉ½‚ʍª‚͔̂畆‚Ö•ä^”ü–
³ƒƒ‚‚â‚¢‚ä‚¢‚¥‚æ‚ç‚è‚é‚ê˜I˜aŒ¾‚¤ƒEƒF‚ðƒAƒCƒEƒGƒIƒJƒLƒNƒPƒRƒTƒVƒXƒZƒ\ƒ^ƒ`ƒcƒeƒgƒ
iƒjƒkƒlƒmƒnƒqƒtƒwƒzƒ}ƒ~ƒ€ƒƒ‚ƒ„ƒCƒ†ƒGƒˆƒ‰ƒŠƒ‹ƒŒƒƒƒCƒEƒEƒFƒ’ƒ“
,ˆ¤ƒEƒG‚¨‘‚«‚­‚¯”Z‚³Ž€‚·”w‘c‚½‚¿‚‚ĂƉ½‚ʍª‚͔̂畆‚Ö•ä^”ü–
³ƒƒ‚‚â‚¢‚ä‚¢‚¥‚æ‚ç‚è‚é‚ê˜I˜aŒ¾‚¤ƒEƒF‚ðƒAƒCƒEƒGƒIƒJƒLƒNƒPƒRƒTƒVƒXƒZƒ\ƒ^ƒ`ƒcƒeƒgƒ
iƒjƒkƒlƒmƒnƒqƒtƒwƒzƒ}ƒ~ƒ€ƒƒ‚ƒ„ƒCƒ†ƒGƒˆƒ‰ƒŠƒ‹ƒŒƒƒƒCƒEƒEƒFƒ’ƒ“

</td></tr></table>
</body></html>


--3. Japanese .html---

<!doctype html public "-//W3C//DTD HTML 
4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html><head>
<META name=content-language content=ja><meta http-equiv=Content-Type 
content="text/html; charset=Shift_jis">
</head><body>
<table width=85%><tr><td>
English Description of the page : 
abcdefghisjklmnopqrstuvwxyz,abcdefghisjklmnopqrstuvwxyz,
abcdefghisjklmnopqrstuvwxyz, abcdefghisjklmnopqrstuvwxyz, 
abcdefghisjklmnopqrstuvwxyz, etc.<p>

Estonian Description of the page : a b d e g h i j k l m n o p r s t u v õ ä ö 
ü,a b d e g h i j k l m n o p r s t u v õ ä ö ü,a b d e g h i j k l m n o p r s 
t u v õ ä ö ü,a b d e g h i j k l m n o p r s t u v õ ä ö ü,etc<p>

Japanese Description of the page : ˆ¤ƒEƒG‚¨‘‚«‚­‚¯”Z‚³Ž€‚·”w‘c‚½‚¿‚‚ĂƉ
½‚ʍª‚͔̂畆‚Ö•ä^”ü–
³ƒƒ‚‚â‚¢‚ä‚¢‚¥‚æ‚ç‚è‚é‚ê˜I˜aŒ¾‚¤ƒEƒF‚ðƒAƒCƒEƒGƒIƒJƒLƒNƒPƒRƒTƒVƒXƒZƒ\ƒ^ƒ`ƒcƒeƒgƒ
iƒjƒkƒlƒmƒnƒqƒtƒwƒzƒ}ƒ~ƒ€ƒƒ‚ƒ„ƒCƒ†ƒGƒˆƒ‰ƒŠƒ‹ƒŒƒƒƒCƒEƒEƒFƒ’ƒ“
,ˆ¤ƒEƒG‚¨‘‚«‚­‚¯”Z‚³Ž€‚·”w‘c‚½‚¿‚‚ĂƉ½‚ʍª‚͔̂畆‚Ö•ä^”ü–
³ƒƒ‚‚â‚¢‚ä‚¢‚¥‚æ‚ç‚è‚é‚ê˜I˜aŒ¾‚¤ƒEƒF‚ðƒAƒCƒEƒGƒIƒJƒLƒNƒPƒRƒTƒVƒXƒZƒ\ƒ^ƒ`ƒcƒeƒgƒ
iƒjƒkƒlƒmƒnƒqƒtƒwƒzƒ}ƒ~ƒ€ƒƒ‚ƒ„ƒCƒ†ƒGƒˆƒ‰ƒŠƒ‹ƒŒƒƒƒCƒEƒEƒFƒ’ƒ“
,ˆ¤ƒEƒG‚¨‘‚«‚­‚¯”Z‚³Ž€‚·”w‘c‚½‚¿‚‚ĂƉ½‚ʍª‚͔̂畆‚Ö•ä^”ü–
³ƒƒ‚‚â‚¢‚ä‚¢‚¥‚æ‚ç‚è‚é‚ê˜I˜aŒ¾‚¤ƒEƒF‚ðƒAƒCƒEƒGƒIƒJƒLƒNƒPƒRƒTƒVƒXƒZƒ\ƒ^ƒ`ƒcƒeƒgƒ
iƒjƒkƒlƒmƒnƒqƒtƒwƒzƒ}ƒ~ƒ€ƒƒ‚ƒ„ƒCƒ†ƒGƒˆƒ‰ƒŠƒ‹ƒŒƒƒƒCƒEƒEƒFƒ’ƒ“

</td></tr></table>
</body></html>
Um, first of all, can you please add the html files as attachments instead of
inline? It makes it a little hard to read the bug with it the way it is. Also,
if there is no whitespace or hyphen break in your text, which I am assuming is
the case, then Mozilla will not wrap it and the table will expand to fit the
contents.

Submit the pages as attachments and then maybe this bug can get somewhere.

Comment 2

13 years ago
Yes, please attach all three of them in separate html files. 
Component: General → Internationalization
Keywords: intl
OS: Windows XP → All
Product: Firefox → Core
Hardware: PC → All
Version: 1.0 Branch → Trunk
Created attachment 170770 [details]
Reporter's Testcase

From reporter:

Attached zip files contains:

western.html
japanese.html
multilingual.php
en.php
ee.php
jp.php

western.html & japanese.html are plain html files to
show the behaviors FF decribed before that the table
width won't wrap around if the page contains mbstring
characters along with western characters within the
same page or table domain whereas IE or NS wrap them
around nicely without any confusion. However, if you
choose Japanese encoding, since western characters are
converted to mbstring format, FF doesn't seem to get
confused and wraps it around.

multilingual.php is basically the same file as aboves,
however it incorporates multilingual switch for
clearer and practical demonstration.

Though it requires php server and additional 3 files;
jp.php, en.php and ee.php have to reside in the same
folder for multilingual.php to run properly.

Also, if using Apache, language congifuration has to
be correct in the config file for Apache.

As for your convenience, I also have uploaded these
files to our php server and they're identical to these
ones in the zip file at :

http://kaboom.ee/langtest/western.html
http://kaboom.ee/langtest/japanese.html
http://kaboom.ee/langtest/multilingual.php

Thank you for your time and look forward hearing your
answer or resolution in this matter.

Ryo

Comment 4

13 years ago
western.html  includes Japanese text in Shift_JIS although the document is
declared as in ISO-8859-1. If you want to include Japanese text in
ISO-8859-1-encoded-document, you should use NCRs. If you need to generate
multilingual documents without using NCRs, you should use UTF-8. 

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 5

13 years ago
This has nothing to do with multilingual pages. The reporter doesn't care how
'Japanese text' in ISO-8859-1-encoded page gets rendered. (as shown below. it's
a total gibberish because he used Shift_JIS in ISO-8859-1-encoded page) He just
wants to have Mozilla break lines in which case it's just a dupe of bug 255990. 

ˆ¤ƒEƒG‚¨‘‚«‚­‚¯”Z‚³Ž€‚·”w‘c‚½‚¿‚‚ĂƉ½‚ʍª‚͔̂畆‚Ö•ä^”ü–³ƒƒ‚‚â‚¢‚ä‚¢‚¥‚æ‚ç‚è‚é‚ê˜I˜aŒ¾‚¤ƒEƒF‚ðƒAƒCƒEƒGƒIƒJƒLƒNƒPƒRƒTƒVƒXƒZƒ\ƒ^ƒ`ƒcƒeƒgƒiƒjƒkƒlƒmƒnƒqƒtƒwƒzƒ}ƒ~ƒ€ƒƒ‚ƒ„ƒCƒ†ƒGƒˆƒ‰ƒŠƒ‹ƒŒƒƒƒCƒEƒEƒFƒ’ƒ“
ƒ
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Mozilla failed to wrap around multilingual texts in the page → Fails to break lines for characters in Latin-1 range

Comment 6

13 years ago
Note that there are a few line breaking opportunities in the gibberish given in
comment #5, but we currently only break on space for text entirely made up of
characters below U+0100. Bug 255990 deals with that problem.



*** This bug has been marked as a duplicate of 255990 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.