When there is a very big favicon firefox uses 100% CPU and leaks memory

RESOLVED DUPLICATE of bug 252401

Status

()

--
minor
RESOLVED DUPLICATE of bug 252401
14 years ago
13 years ago

People

(Reporter: THe_ZiPMaN, Assigned: bugzilla)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
The site emsc-csem.org uses a favicon image
(http://www.emsc-csem.org/favicon.ico) that is a 1400KB large bmp.
When you load the page in the URL with Mozilla Firefox 1.0 (I use the version
distributed with Debian Sarge package 1.0-4, gecko 20041128, not tested other
versions/other platforms) the CPU rise to 100% and the program starts to
allocate memory (200MB in 30 seconds) until crash. 
Disabling the load of favicons (browser.chrome.favicons=false) I can browse the
site without any problem.
The faviconsize is supposed to be restricted to a few kb or so.
Or is bug 252401 just about bookmarks ?
I'm sure we had a (fixed) bug about a huge favicon causing a crash ~6 month back
or so.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

*** This bug has been marked as a duplicate of 252401 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.