HTML entities displayed differently on "View Source" and "View Selection Source"

VERIFIED DUPLICATE of bug 236465

Status

()

Toolkit
View Source
--
minor
VERIFIED DUPLICATE of bug 236465
13 years ago
9 years ago

People

(Reporter: Liron Newman, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
When viewing the source of the example URL you get the following text:
<a href="mailto:test&#x25;&#52;&#x30;no-such.address.com">try to view my source!</a>

However, if you select the text and then view selection source, you see this text:
<a href="mailto:test%40no-such.address.com">try to view my source!</a>

Happens on Firefox 1.0 on Win2k and reportedly on Mac as well.

*** This bug has been marked as a duplicate of 236465 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
Created attachment 170768 [details]
Test case (same as http://eesh.net/ent.html)

Use this if the page is down for some reason.

Comment 3

13 years ago
Do we need to open a new bug that represent the view that this is a bug in the
view source, and not a window naming problem? In other words, when the bug is
fixed the view selection source will show the same identical characters as view
source.
(In reply to comment #3)
> Do we need to open a new bug that represent the view that this is a bug in the
> view source, and not a window naming problem? In other words, when the bug is
> fixed the view selection source will show the same identical characters as view
> source.

That wouldn't work. See bug 275556 comment 1.
Status: RESOLVED → VERIFIED

Comment 5

13 years ago
When I view source, I want to see the JS and not the content it generated.
(In reply to comment #5)
> When I view source, I want to see the JS and not the content it generated.

Well, you're not like most web developers. You can use View->Page Source. There
is absolutely no plan to change the View Selection Source behavior. It would be
a significant loss of functionality.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.