Segfault when default font has wrong privileges

RESOLVED DUPLICATE of bug 183729

Status

()

Core
Layout
--
critical
RESOLVED DUPLICATE of bug 183729
14 years ago
14 years ago

People

(Reporter: David Palm, Unassigned)

Tracking

({crash})

1.7 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Using firefox 1.0, debian unstable (x86), xorg 6.8.1 I have experienced
segfaults in the following situation:
- login as normal user
- start ff
   - normal web navigation works fine
   - visit a remote XUL page with a textbox input field (<xul:textbox/>)
   - at first keypress ff segafults

Starting ff as root, everything works fine.
Using strace I could se two open() calls for the default font in
/usr/local/share/fonts. The font file had the following privs set: "-rw-r-----".
Changing that to "-rw-r--r--" everything solves the problem.

Still, FF should not segfault when user set default font is not available.

Updated

14 years ago
Keywords: crash

*** This bug has been marked as a duplicate of 183729 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.