Altering certain styles of a designMode iframe causes designMode to die. [midas]

VERIFIED FIXED

Status

()

Core
Editor
VERIFIED FIXED
14 years ago
12 years ago

People

(Reporter: James Sleeman, Assigned: Joe Francis)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.19 KB, text/html
Details
(Reporter)

Description

14 years ago
Sumamry says it all really, changing style.display or style.position of an
iframe with designMode on causes designMode to turn off. 

I'll attach a testcase which walks you through thw two main problems.

This is /almost/ able to be worked around (by turning it back on), but it means
that any selection in the designMode on iframe is lost (not the content of the
selection, just the selection (hilite) itself).  Unfortunatly I can't find a way
to grab selection, turn off designMode, do the style change, turn on designMode
and reselect the previously selected text.
(Reporter)

Comment 1

14 years ago
Created attachment 170827 [details]
Testcase

Comment 2

14 years ago
With trunk build 20050110 on Win XP, the designmode stays when clicking the
first button, but lost on the second (position:relative)
The first button actually does absolutely nothing in a current build, since the
display is not changed when all is said and done.  That's why it doesn't cause
any problems.

For the rest, a frame reconstruct will destroy the presshell in the iframe.  It
sounds like Midas doesn't deal with that very well.

Note that selection will definitely get destroyed with the presshell, so that
will be a problem even if this bug is fixed....
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Altering certain styles of a designMode iframe causes designMode to die. → Altering certain styles of a designMode iframe causes designMode to die. [midas]
Created attachment 175929 [details]
Fixed testcase

Same testcase as before, but now both ways cause designMode not to work anymore
(as already described in this bug and testcase).
Attachment #170827 - Attachment is obsolete: true
Blocks: 284245

Comment 5

13 years ago
Also turns off when changing visibility.

Updated

13 years ago
Keywords: testcase
This was fixed by bug 284245.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
https://bugzilla.mozilla.org/attachment.cgi?id=175929 is now working fine for me
using build Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050628 on Windows XP Seamonkey trunk.

Verified FIXED
Status: RESOLVED → VERIFIED

Comment 8

13 years ago
I'm using deerpark from July 12
and when I use a RichEdit I can only type if there is text already.
and I have to click on a line that has text. if there is no text, there is no
where to click.
Mathieu Jobin, that doesn't sound like it's related to this bug at all.  Please
file a new bug on that, ok?  One bug per issue.
You need to log in before you can comment on or make changes to this bug.