accesskeys in html hijack browser functionality

RESOLVED DUPLICATE of bug 128452

Status

()

Firefox
Keyboard Navigation
--
minor
RESOLVED DUPLICATE of bug 128452
14 years ago
14 years ago

People

(Reporter: dpk, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
When you go to the above link, or any Bugzilla show_bug.cgi link, you will be no
longer able to access the bookmarks menu via alt-B, the tools menu via alt-T,
view via alt-V, edit via alt-E, and probably most "shockingly" if I were a
newbie (shocking that any site can do this!), alt-H for the help menu.

Method for duplicating the bug:

0) Download Firefox 1.0 (Windows XP), or download its source and build it (FreeBSD).
1) Go to https://bugzilla.mozilla.org/show_bug.cgi?id=236541
2) Press alt-b.
3) Watch as it takes you to the "Bug 236541 blocks" box instead of the bookmark
menu.

Request:

It ought to be impossible for a random website to be able to hijack any of the
standard key combinations for menu access, especially in this world where people
are so concerned over spyware taking over their computers. If it cannot be made
impossible, it ought to be an option, tweakable in preferences, defaulted to
"no, I do not want web pages to be able to hijack alt-key combinations". Or at
the very least, there should be an about:config option, defaulted either way, so
the feature can be disabled somehow.

Comment 1

14 years ago
Dupe of bug 128452

*** This bug has been marked as a duplicate of 128452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.