saved searches that search message body do not update correctly

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: asa, Assigned: Bienvenu)

Tracking

({fixed1.8.1})

unspecified
Thunderbird2.0
x86
Windows XP
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
If you create a saved search folder using the "entire message" quicksearch
field, that saved search folder will not update properly. The folder unread
count does not update when new messages come in and it does not update when
unread messages are marked as read (even from within the saved search folder.)

Steps to reproduce: 

1. focus the quicksearch field, select "entire message", and and type in the
letter "a". 
2. if this gives results, then save that as a search folder. if no results, your
mailbox must be empty :-)
3. enter the saved search folder and mark some messages as unread and then as read. 
4. enter your inbox and mark some messages as read and then unread. 
5. wait for new unread mail to arrive.

results: the saved search folder does not update unread mail count until you
leave it and reselect it, even in the case that you marked the messages read
within the saved search folder. 

expected results: the unread message count should reflect reality as best as it
can and hopefully better than it is now.

additional info: this is the case whether you have selected to search online or not.

Comment 1

13 years ago
This is related to Bug#270232 I'd imagine
(Reporter)

Comment 2

12 years ago
Scott, this is the bug I was just talking to you about. Turns out there was a report on this issue :-) 

- your friendly neighborhood saved search power user

Updated

12 years ago
Target Milestone: --- → Thunderbird2.0
(Assignee)

Updated

12 years ago
Assignee: mscott → bienvenu
(Assignee)

Comment 3

12 years ago
Created attachment 210414 [details] [diff] [review]
proposed fix

comments in the patch say it all...
Attachment #210414 - Flags: superreview?(mscott)

Updated

12 years ago
Attachment #210414 - Flags: superreview?(mscott)
Attachment #210414 - Flags: superreview+
Attachment #210414 - Flags: branch-1.8.1?

Comment 4

12 years ago
Asa says he'll verify this for us on the trunk if we can get it checked there for him :).
(Assignee)

Comment 5

12 years ago
fixed on trunk, thx, Asa.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
Asa, can you let us know how this is treating you on the trunk these days? 

Comment 7

12 years ago
Comment on attachment 210414 [details] [diff] [review]
proposed fix

should we try this on the 1.8.1 branch david? Maybe we can get asa to verify it for us there :)
Attachment #210414 - Flags: approval-branch-1.8.1? → approval-branch-1.8.1+
(Reporter)

Comment 8

12 years ago
Yeah. This worked for me on the trunk. I'm back on the branch right now so I'd be thrilled to verify it there too.
(Assignee)

Comment 9

12 years ago
yeah, I'll put this on the branch 
(Assignee)

Updated

12 years ago
Keywords: fixed1.8.1
You need to log in before you can comment on or make changes to this bug.