Trash bin disappears when emptied

RESOLVED DUPLICATE of bug 341417

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 341417
13 years ago
8 years ago

People

(Reporter: markus.nehlig, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
1. I imported my mails from my existing Outlook 2K3 account.
2. TB created a new folder structure with my Outlook folders below the TB local
folders.
3. I then moved the mails from the Outlook inbox to the TB local inbox and the
"sent items" from Outlook to the TB "sent items" respectively. Up to here
everything ok.
4. Now I tried to delete the now empty "old" Outlook folder with its empty
subfolders. This action moved the folder to the trash bin.
5. When I tried to empty the trash bin, the whole trash bin simply disappeared.
After that, it was impossible to delete any other item (e.g. mails).
6. I restarted TB: the trash bin is there again, however the deleted Outlook
folder as well.

Conclusion:
- I didn't find a way to delete the Outlook folder.
- The trash bin disappears until the next restart when it contains one or more
deleted folders and you empty it (is not the case with mails).
- Win XP Pro SP2, TB 1.0.

Comment 1

13 years ago
The same happens to me in Aviary 1.0.1 20050225.
It happens about 95%.
I already uninstalled and reinstalled thunderbird.

Comment 2

13 years ago
Have also seen this, more than once, with Thunderbird 1.0.2  It is intermittent, 
and restarting Thunderbird makes it reappear.

Comment 3

12 years ago
Contrary to the original reporter, i get this also when the trash contains only
messages but also when it contains deleted folders.

As i reported in bug 88515, i get this error and then one or more nstmp folders
regularly in  1.0.6 (20050716) in the following situation: 
After deleting messages and clicking File -> Empty Trash, the trash folder often
"disappears" (only in the UI). If i shut down and restart TB, the trash folder
reappears, and then compacting works correctly. But if i compact before
restarting, i.e. with an "invisible" trash folder, i get an nstmp folder (and a
new one for each compacting attempt until i restart TB and the trash folder
reappears).

Comment 4

12 years ago
TBird version 1.0.7 (20050923) on WinXP Pro SP2
I also experience this problem. If I choose Empty Trash, the entire folder disappears. After closing and relaunching TBird, the Trash folder reappears along with all its contents. It is possible to select all messages in the Trash folder and delete them with the Delete key; that does not cause the folder to disappear.
we got feedback from a user confirming that he still sees the bug after upgrading to 1.5
Version: 1.0 → 1.5

Comment 6

12 years ago
Just saw this today with my 2 POP3 accounts.   Restarting Thunderbird 1.5 caused them to re-appear.

Comment 7

12 years ago
I do know what happened but I can not delete any messages and I can not see Trash folder anymore..... I do not remember what 'criminal' action I did... :O)

   Vadim Schetinkin, 

   PS: Any ideas what should I do now?

Comment 8

12 years ago
Created attachment 218177 [details]
More about missing trash folder

I think I've got the same 'missing trash folder' problem.  Occasionally I can't delete mail, my trash folder has disappeared.  I find that trash.msf has disappeared.  If I then shut down TB (1.5), delete trash.(null) and restart TB, all is fixed.  Simply restarting TB doesn't fix the problem; I must first delete trash.(null).  So what is deleting trash.msf?

Comment 9

12 years ago
I am having the same issue.  Trash does not appear in trash bin, until I click on it.  Then the "deleted" messages appear, but if I try to empty the trash bin, the trash bin completely disappears, only to reappear (with messages STILL in it) when Thunderbird is restarted.

The only way to permanently delete the messages is to manually delete them one by one.  I even tried uninstalling and re-installing the most recent version of Thunderbird, and it did nothing to alleviate the problem.

Is ANYONE working on this problem?  Seems to me it's been almost a month since the first reported instance of this problem, and no one seems to have followed up or given any possible work-arounds or solutions to try.

Thanks!
Brooke

Comment 10

12 years ago
possible duplicate? bug 341417
QA Contact: general

Comment 11

10 years ago
(In reply to comment #10)
> possible duplicate? bug 341417
> 

I was about to say that too, the other having more recent act and some mention of other bugs also

only here appears this outlook migration.
Assignee: mscott → nobody
Component: General → Mail Window Front End
QA Contact: general → front-end

Comment 12

9 years ago
bug 341417 is waiting on response to bug 341417 comment 23.
same question applies here
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 341417
You need to log in before you can comment on or make changes to this bug.