scollbar thumbs not rendering

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Syd Logan, Assigned: Eric Vaughan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Unable to reproduce.)

(Reporter)

Description

18 years ago
Start mozilla. If the default page didn't load (which it doesn't for me), load a
page. Notice the scrollbar draws but the thumbs don't until you click on the
area where they should be.

Comment 1

18 years ago
I didn't see this in today's verfication builds. What build are you using?  Why
did you mark this critical severity?  That's reserved for crash, data loss and
severe leaks.  Since there is a workaround, this isn't even major severity.

Comment 2

18 years ago
Don't see this in today's verification build either, nor in a debug build of the

tip from 2 hours ago.resolving as wfm, if you still see it please reopen with

sufficient information to reproduce.

Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 3

18 years ago
This seems to work fine if you start with the sidebar *open*, and a URL such as 
Tinderbox loads in the sidebar.

If you launch with the sidebar closed, then I see what syd sees. So to 
reproduce:

1. Create a new profile and launch that profile.
2. Click on grippy to close sidebar (note that default home page does not load)
3. Shutdown and relaunch (still no default home page)
4. Click on bugzilla personal toolbar link (or any other).

Results: no arrows on scrollbars

This happens whether the sidebar is minimized (by using the grippy) or 
completely off, by use View - Sidebar.

Re-opening and marking beta1, but I'm thinking this might go away once the 
default open page problem is fixed, bug 26959. But then the problem will still 
occur for people who start with about:blank as their home page. Of course, I 
could be completely wrong.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 4

18 years ago
I still don't see this, and have been launching with the sidebar closed, also
tried collapsed. I tried it with about:blank as my default page (app froze
trying to create new profile.) With about:blank I get no page, hence no
scrollbars at all.  Once I load any page, I have complete scrollbars, both
thumbs and arrows.  Does it really require a new profile?  If so, how are you
making one today?
(Reporter)

Comment 5

18 years ago
We get this pretty regularly in the commercial tree, with IM definitely.

Comment 6

18 years ago
I'm using mozilla, not commercial build, which launches okay.

to make a new profile, I just do a rm -fr ~/.mozilla then launch and I'm forced 
into it, but I don't know if that is a guaranteed way of reproducing this bug

Comment 7

18 years ago
I'll give this to evaughan, but I still can't reproduce it. We need more info in 
the bug report.
Assignee: trudelle → evaughan
Status: REOPENED → NEW
Whiteboard: Unable to reproduce.
(Assignee)

Comment 8

18 years ago
targeting
Status: NEW → ASSIGNED
Target Milestone: M14
(Assignee)

Comment 9

18 years ago
targeting
Target Milestone: M14 → M15

Comment 10

18 years ago
Mass-moving most M15 bugs to M16
Target Milestone: M15 → M16

Comment 11

18 years ago
reducing severity to normal.
Severity: critical → normal

Comment 12

18 years ago
spam, open xptoolkit qa contact moving over to jrgm
QA Contact: paulmac → jrgm

Comment 13

18 years ago
I can't reproduce this at all on a linux build for today (and I see that it's 
been a while since any one has positively seen it). Marking WORKSFORME, but 
... reopen if there is a reproducible, etc., etc. ...
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 14

17 years ago
Works for me:
Platform: PC
OS: Redhat 6.2 Linux 2.2.14
Mozilla Build: 2000103108 M18 Trunk Build

Marking as verified.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.