Closed Bug 277995 Opened 15 years ago Closed 11 years ago

DHTML not rendering properly in Firefox.

Categories

(Core :: Layout: Tables, defect)

1.7 Branch
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: matt.hershberger, Assigned: bzbarsky)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

When a table that is created with css is placed within a cell in an normal html
and javascript modifies rows within the table created using css the resulting
html is not rendered properly. The css rows are pushed down by a number that is
relative to the number of elements in the row. I have an example to illustrate
the problem.
Attached file Testcase showing bug
Maybe 
http://validator.w3.org/check?uri=http%3A//nicole.lightsp.com/ff_bug.html
may help you correct the errors ?

And check JSconsole too
Keywords: testcase
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: 1.0 Branch → 1.7 Branch
Document now validates xhtml 1.0 compliant. Problem is still exists. No Javascript errors occur on the 
page.
Depends on: 162063
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050201 Firefox/1.0+

Yeah, seeing the same here.

Did you try changing CSS to get it right, I think I've read an article somewhere
about display:table issues with Mozilla.

See if any of these:
https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=display%3Atable&product=Core&product=Mozilla+Application+Suite&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&resolution=---&chfieldto=Now

fit ?
None of the bugs listed at https://bugzilla.mozilla.org/buglist.cgi?
query_format=advanced&short_desc_type=allwordssubstr&short_desc=display%3Atable&product=Core
&product=Mozilla+Application+Suite&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSI
GNED&bug_status=REOPENED&bug_status=RESOLVED&resolution=---&chfieldto=Now match the 
problem I am having. My problem only occurs when the element is changed multiple times with 
javascript. The first time the javascript is executed the result is fine but subsequent executions result in 
the rows being pushed down. It looks like the margin or padding width is not being removed even 
though the rows were removed. I worked around the problem by always writing tables in css and not 
using the html table tags.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050906
Firefox/1.4 ID:2005090616

This behavior persists in the above nightly.  Confirming and moving to
Core/Table: Layout.
Status: UNCONFIRMED → NEW
Component: Layout → Layout: Tables
Ever confirmed: true
QA Contact: layout → layout.tables
Fixed by checkin for bug 162063.  Added test.
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Assignee: nobody → bzbarsky
You need to log in before you can comment on or make changes to this bug.