Download Manager shows incorrect %age for multiple downloads

VERIFIED DUPLICATE of bug 245829

Status

()

Toolkit
Downloads API
--
minor
VERIFIED DUPLICATE of bug 245829
14 years ago
10 years ago

People

(Reporter: Robert Langdon, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier:  Firefox/0.10.1

While downloading multiple files using download manager, the window tab shows
the %age download. This %age shown , however is only for the first file but the
description says...e.g. 33% of 4 Files. For huge multiple downloads, such
incorrect info is very misleading and frustrating.

Reproducible: Always

Steps to Reproduce:
1. Start download of more than 1 files, say 4
2. After some time note the %age download from Downloa Mgr tab
3. From actual sizes calculate the overall %age and compare with value in step 1.

Actual Results:  
The values in Step 1 and Step 3 do not match, hence the test fails.

Expected Results:  
Either individual download %ages should be shown or an aggregate should be taken
as...%age = ((Total Downloadable Date)/(Total Downloaded Date))*100

*** This bug has been marked as a duplicate of 245829 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.