Compile-time problem on AIX in nsISupportsUtils.h

VERIFIED DUPLICATE of bug 28114

Status

SeaMonkey
Build Config
P3
normal
VERIFIED DUPLICATE of bug 28114
18 years ago
13 years ago

People

(Reporter: Ciaran Deignan, Assigned: Jim Dunn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
On AIX-4.3.2, with the IBM compiler (ibmcxx-3.6.6), compiling the "nightly
build" of 13th Feb, the following error is detected when compiling
./layout/base/src/nsGenericElement.cpp :
"../../../dist/include/nsCppSharedAllocator.h", line 90.16: 1540-252: (W) The 
destructor for "unsigned short" does not exist. The call is ignored.
"../../../dist/include/nsISupportsUtils.h", line 863.1: 1540-068: (S) Function 
overloading conflict between "nsrefcnt(nsIAtom*const)" and "nsrefcnt(nsIAtom*)".

This "Severe" error prevents the compilation from continuing. I have the
complete compilation log available if more information is required.
(Assignee)

Comment 1

18 years ago
diffs to get around this are in the other bug.
I am hoping to check the fix in this afternoon

*** This bug has been marked as a duplicate of 28114 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.