In message filter "move to" and "copy to" cannot be used together

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Amit, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
In message filters a new message filter was created. I have configured two imap
mail accounts in thunderbird. 
3 options were given with an "OR" condition for selecting a message. 
I wanted the message to be sent to two separate folders, so i copied to one
folder and moved to another. 
Problem: The selcted mails were only "moved" to a folder, they were never copied
to the second folder.

Comment 1

13 years ago
Under windows is the same. A workaround for this is to create two filters, first
for copying and second for moving. But this is annoying. :-(

Comment 2

13 years ago
While I was researching this bug, I found that the latest trunk has no 'copy to
folder' action in the filter action list. Does anyone have idea on this change?

Comment 3

13 years ago
The removal of that filter action has broken TB for me. I simply can't upgrade
if this doesn't go back in. What was the rationale for removing it?
(Assignee)

Comment 4

13 years ago
(In reply to comment #3)
> The removal of that filter action has broken TB for me. I simply can't upgrade
> if this doesn't go back in. What was the rationale for removing it?

It's there in the 1.1 nightly test builds. It has not been removed. 

Comment 5

13 years ago
(In reply to comment #2)
> While I was researching this bug, I found that the latest trunk has no 'copy to
> folder' action in the filter action list. Does anyone have idea on this change?

This might be caused by my environmental issue. After cleaning up build tree and
rebuiling the source, I confirmed that there is copy action in the latest trunk.
Sorry for confusion :-)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.