Sidebar autoscrolls to a selected item when resizing

RESOLVED DUPLICATE of bug 170045

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 170045
13 years ago
13 years ago

People

(Reporter: Percy Cabello, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If you resize the sidebar (tried with Bookmarks and History) while the focus is
on  an item currently not displayed, it will autoscroll to the focused item.

It's annoying because my main reason to resize is to read a complete title
whether it's focused (selected) or not.

Reproducible: Always

Steps to Reproduce:
1. Select an item in History/Bookmarks sidebar
2. Scroll until the selected item is not displayed
3. Resize the sidebar

Actual Results:  
The sidebar autoscrolls to display the selected item.

Expected Results:  
Stay where it was

Comment 1

13 years ago
(In reply to comment #0)
> If you resize the sidebar (tried with Bookmarks and History) while the 
> focus is on  an item currently not displayed, it will autoscroll to the 
> focused item.
> 
> It's annoying because my main reason to resize is to read a complete 
> title whether it's focused (selected) or not.

Do you mean resize the sidebar wider?

I suggest asking for a tooltip to how the the full title (and 
optionally the URL on a second line)

See Bug 170045 "Resizing sidebar scrolls Bookmarks/History to selected bookmark"

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 170045 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.