Closed Bug 278117 Opened 15 years ago Closed 14 years ago

Add accesskey for Lightning extension

Categories

(Calendar :: Lightning Only, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla.e.dserodio, Assigned: jminta)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041206 Thunderbird/1.0

Ctrl+1 opens the Messages window
Ctrl+2 opens the Addresses window

Ctrl+3 should open a Calendar window

Reproducible: Always

Steps to Reproduce:
1. Press Ctrl+3
2.
3.

Actual Results:  
Nothing happens

Expected Results:  
A Calendar window should've been opened
QA Contact: gurganbl → sunbird
Marking WONTFIX because XPI-only?
No. This still applies to Lightning. The accel+1, 2, 3 descriptions are still correct accesskeys

Assignee: mostafah → nobody
Status: UNCONFIRMED → NEW
Component: Sunbird and Calendar-Extension Front End → Lightning
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: Add keyboard shutcut for Calendar extension → Add keyboard shutcut for Lightning extension
Summary: Add keyboard shutcut for Lightning extension → Add accesskey for Lightning extension
Attached patch add ctrl+3Splinter Review
Patch adds ctrl+3 to do the equivalent of clicking in the minimonth.  That is, it shows whatever view was previously shown.  Since the minimonth is now in sync with the views, this will return the user to exactly the state they were previously in.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #225793 - Flags: first-review?(dmose)
Comment on attachment 225793 [details] [diff] [review]
add ctrl+3

r=shaver
Attachment #225793 - Flags: first-review?(dmose) → first-review+
patch checked in.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: Lightning Only. Be afraid for your sanity!
QA Contact: sunbird → lightning
You need to log in before you can comment on or make changes to this bug.