browser.tabs.opentabfor.windowopen has 0 (zero) effect on anything

RESOLVED DUPLICATE of bug 105547

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 105547
13 years ago
13 years ago

People

(Reporter: tsurusennin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 7.54  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217

I made a post at http://forums.mozillazine.org/viewtopic.php?t=199507 .

As far as I can tell from a web and usenet, nobody has gotten this option to 
work yet. A search for "windowopen" didn't find much in Bugzilla, but this is 
the bug that's keeping me in Opera.

Reproducible: Always

Steps to Reproduce:
1. Go to just about any phpBB, vBulletun or UBB forum
2. Find a post with a link in it
3. Click
Actual Results:  
New window spawned

Expected Results:  
New tab spawned

Comment 1

13 years ago
No wonder, there is no backend for this pref :).
As a workaround you can do one of the following:
1.) Use middle click, then the link will open in a new tab
2.) Use Ctrl+left click, will do the same as 1.)
2.) Add user_pref("browser.block.target_new_window", true); to your user.js,
then it will open such links in the same tab/window.

*** This bug has been marked as a duplicate of 105547 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.