Password manager should fill passwords as page loads

RESOLVED DUPLICATE of bug 221634

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 221634
13 years ago
10 years ago

People

(Reporter: Tom Graham, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

On slow loading websites, it can often be a hassle / annoyance to have to wait
for it to load before you can login; this is because Firefox auto-completes
stored password information only once the page has completed loading. What would
be ideal  would be Firefox auto-completing as it renders the page a user is
viewing. Problem pages include sites that use externally (i.e. non-local server)
hosted adverts, or sites that use solutions that ask users to view a 1px x 1px
image for tracking purposes. Often laggy, it can be a pain to have to wait for
these un-imporant elements to load before Firefox places password / username
information on websites login boxes.

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
This may be a good idea but some people may not always want to use the same
username and passwords all the time on certain websites and have several that
are available in the Password Manager. This then means that they would have to
do twice the amount of 'clicking' to enter the username and password that they
wanted to use.
search before you file a bug

*** This bug has been marked as a duplicate of 221634 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.