"make install" installs nspr-config in /usr/local/bin though prefix=$HOME/mozilla

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: vincent-moz, Assigned: wtc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041208
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041208

I've just compiled Mozilla with "make -f client.mk" and "ac_add_options
--prefix=$HOME/mozilla" in my .mozconfig file (as usual), but:

dixsept:...oz-source/mozilla> make install
/usr/bin/make -C nsprpub real_install DESTDIR=
libdir=/usr/local/lib/mozilla-1.8a6 includedir=/usr/local/include/mozilla-1.8a6/nspr
make[1]: Entering directory `/home/lefevre/software/moz-source/mozilla/nsprpub'
cd config; /usr/bin/make -j1 real_install
make[2]: Entering directory
`/home/lefevre/software/moz-source/mozilla/nsprpub/config'
../config/./nsinstall -t -m 0755 nspr-config /usr/local/bin
../config/./nsinstall: cannot create /usr/local/bin/nspr-config: Permission denied
make[2]: *** [real_install] Error 1
make[2]: Leaving directory
`/home/lefevre/software/moz-source/mozilla/nsprpub/config'
make[1]: *** [real_install] Error 2
make[1]: Leaving directory `/home/lefevre/software/moz-source/mozilla/nsprpub'
make: *** [install] Error 2

Fortunately, I didn't try that under root, otherwise system files could have
been overwritten!

Reproducible: Always
Assignee: general → wtchang
Component: Installer → NSPR
Product: Mozilla Application Suite → NSPR
QA Contact: bugzilla → wtchang
Version: unspecified → other
(Reporter)

Comment 1

14 years ago
The problem was due to a .mozconfig file in the tarball (as noted in bug
278253), with the consequence that my personal .mozconfig wasn't taken into account.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.