using_firebird.xhtml should be named using_firefox.xhtml

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
14 years ago
2 years ago

People

(Reporter: RyanVM, Assigned: jwalden+fxhelp)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Seems to me that
mozilla/browser/components/help/locale/en-US/using_firebird.xhtml shouldn't be
named after Firebird. A quick look in LXR suggests that it would be relatively
easy to change this, as there's only a few files which reference it.

I can write the patch for those files, but I don't know how rename something in
the source tree.
(Reporter)

Comment 1

14 years ago
Created attachment 171150 [details] [diff] [review]
Patch for all instances of using_firebird.xhtml in the source code.
(Reporter)

Comment 2

14 years ago
Comment on attachment 171150 [details] [diff] [review]
Patch for all instances of using_firebird.xhtml in the source code.

Would need to have using_firebird.xhtml renamed to using_firefox.xhtml in the
source tree as well.
(Assignee)

Comment 3

14 years ago
The name of the file is essentially meaningless, and unfortunately moving files
(and keeping the revision histories) is not trivial with the current source code
management programs used.  If I had control of this I might do it, but since I'd
be foisting it onto someone else (and a *paid* someone else who works for the
Mozilla Foundation, at that) I won't even try to get it done.

Put simply, this is not worth the effort.  (Particularly when we have real
problems that actually do matter, such as Thunderbird Help documentation work at
<http://wiki.mozilla.org/index.php/Thunderbird:Help_Documentation:Base>.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.