Can't use "group by sort" on the "flag" field.

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: joshs, Assigned: Bienvenu)

Tracking

({fixed1.8.1})

Trunk
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
I use the "flag" field on my IMAP accounts to note items that I need to deal
with or respond to later. It would be nice to be able to use "group by sort" on
that field as I can on others. For some reason that menu item is disabled when I
sort by flag.

Comment 1

14 years ago
I think this is not supported because the flag is binary -- if you're sorting by 
flag, it's easy enough to get them all clustered and to find the cluster.
The advantage to Group By Sort By Flag would be that the non-flagged messages 
could be hidden by collapsing their group.

xref bug 238631, bug 277982
OS: Windows XP → All
Hardware: PC → All
Version: 1.0 → Trunk
(Reporter)

Comment 2

14 years ago
I guess this is one of those "but Outlook can do it" kind of things. In Outlook
(or Entourage or Mail.app) I can group by flag and then do a secondary sort by
date. There is no way in Thunderbird for my flagged items to appear at the top,
and the newest non-flagged ones to appear beneath them, as far as I can tell.
(Assignee)

Comment 3

14 years ago
it's trivial to do - I just didn't do it because it didn't seem very useful and
I didn't think anyone would want it...but now I know better :-)
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
(In reply to comment #2)
> In Outlook [...] I can group by flag and then do a secondary sort by
> date.

Secondary sort is not implemented: bug 57898.

> There is no way in Thunderbird for my flagged items to appear at the top,
> and the newest non-flagged ones to appear beneath them, as far as I can tell.

If bug 238631 were fixed, that particular issue would more-or-less go away.

Comment 5

13 years ago
I *think* this is a related comment:

I'd like to be able to see *only* the flagged messages and then with that filter applied, sort them newest-to-oldest.

There doesn't seem to be a filter (like there is for, say, unread messages) to view only flagged messages, so the best I can do is sort on this column. Unfortunately, this makes the messages sort oldest-to-newest.

I'd like to be able either to filter based on this flag or to somehow reverse the secondary sort order (or to specify a second sort criteria) so that I can see ony flagged items and then in reverse chronological order.

I suppose the "group by" feature would do this...? If only it were enabled for this attribute...

Comment 6

13 years ago
(In reply to comment #3)
> it's trivial to do - I just didn't do it because it didn't seem very useful and
> I didn't think anyone would want it...but now I know better :-)

Being able to sort emails by flag is an EXTREMELY useful feature to me, especially when I work with hundreds of emails a day and need to flag certain emails so that they stay at the top of the pack and don't get buried.

If it's easy to implement, then I beg you to please do so in the next version. :)

(Assignee)

Comment 7

13 years ago
fixed by patch in bug 238631, on trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.