Adding a dataset fails, but "Grand Total" still appears.

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
Reporting/Charting
RESOLVED FIXED
14 years ago
5 years ago

People

(Reporter: cso, Assigned: gerv)

Tracking

2.19.1
Bugzilla 2.20
Bug Flags:
approval +

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
This may not make much sense, but I'll try anyway...

If I go to create a chart, I can add "Bugzilla / Bugzilla 2.18 / Blockers" to
the Dataset to chart.

If I then try to add "Browser / Chatzilla / Open Bugs" I get the Grand Total row
appearing, but not the actual row I tried to add. Dave seemed to suggest this is
because Browser/Chatzilla doesn't exist (so likely the search doesn't).

If I try to add that straight off, it doesn't do anything - it returns me back
to the page, although there is no error, presumably for the same reasons.

Colin

Comment 1

13 years ago
reporter - please refile with greater detail if this is still a problem. And
please list the EXACT numbered steps from beginning to end (as you list them
below, it doesn't seem to me that you'd get anything useful)

marking INVALID because product names have changed (browser no longer exists) -
impossible to attempt to reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 2

13 years ago
1) Go to https://bugzilla.mozilla.org/
2) Click Summary reports and charts - https://bugzilla.mozilla.org/report.cgi
3) Click New Charts - https://bugzilla.mozilla.org/chart.cgi
4) Add "Bugzilla / Open Bugs / Enhancements" Dataset to the Chart, click Add To List
5) Add "Browser / Chatzilla / Open Bugs" to the same chart.

Actual Results:

The new set is not added, but Grand Total appears.

Expected Result:

The new set to not be added, and Grand Total to not appear - since there is
still only one data set.

Comment 3

13 years ago
list of Charting products has not caught up with what is actually in bugzilla
since the reorg (?) - Browser is not valid product.

Proof
Click New Charts - https://bugzilla.mozilla.org/chart.cgi
"Browser / Chatzilla / Open Bugs" 
click add to list

Results:
List Of Data Sets To Plot
None
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 4

13 years ago
Created attachment 180187 [details] [diff] [review]
Patch v1 (Untested)

This bug looks as if its due to the fact that the gt variable (which governs
whether the grand total is shown or not) is set BEFORE any of series are added
- so if one fails, which would be the one that takes it over the 2 value; it
will add the line regardless.

This patch should fix it in theory;
Attachment #180187 - Flags: review?(gerv)
OK, the underlying bug is that people should not be able to view charts that
they can't add. But given that bug exists, this is also a problem which should
be fixed. We should indeed add GT depending on the actual number added, not the
number requested.

Gerv
Attachment #180187 - Flags: review?(gerv) → review+
Flags: approval?
Does this affect 2.18?  This qualifies for a backport if so.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: approval? → approval+
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.20
I can't reproduce the problem in 2.18 - but then, perhaps it's not displaying
inaccessible datasets, so it's harder to trigger. When I solve that one, if
that's present in 2.18, we'll revisit this bug.

Gerv
Fixed.

Checking in ./Bugzilla/Chart.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Chart.pm,v  <--  Chart.pm
new revision: 1.8; previous revision: 1.7
done

Gerv
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.