Firefox doesn't handle files > 2GB properly

VERIFIED DUPLICATE of bug 228968

Status

()

VERIFIED DUPLICATE of bug 228968
14 years ago
10 years ago

People

(Reporter: jason-mozilla, Assigned: bugs)

Tracking

1.7 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
When downloading a file > 2GB, firefox didn't finish downloading the file, and
the UI got kind of messy.

The file in question is 3475738628 bytes.  I'm not setting the Content-Length
header since WebSphere chokes on it.

The download manager window was redrawing the file size very quickly for the
first few seconds, and then stopped updating as FireFox took up 100% cpu time.

The download stopped at 3194220544 bytes in the .part file, and the socket was
reset (as per the error on the server).  Firefox's download window doesn't
indicate that the transfer was completed and is stuck at "-1074956 KB at
-1990.-9 KB/sec; unknown file size"
(Reporter)

Comment 1

14 years ago
Never mind about the transfer not completing; I ran out of disk space (but no
error occurred).

The GUI is still messed up, however.  If you watch, you can see it flip to
negative after 2GB. 

A clarification on the redraw issue- it looks as if firefox is trying to redraw
the window too quickly.  It redraws about 10 times in one second then pauses for
about 10 seconds.  Does it need some sort of throttle to limit the # of
redraws/second?  The transfer is over 100Mbit, so it's going about 5000-10000KB/s.

*** This bug has been marked as a duplicate of 228968 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.