Auto-complete does not work on some sites.

RESOLVED INVALID

Status

()

Toolkit
Password Manager
RESOLVED INVALID
13 years ago
9 years ago

People

(Reporter: jcaesar, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050113 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050113 Firefox/1.0+

On several sites, auto-complete does not work (not including Flash forms).
On some sites it works intermitantly (every other field).
On some sites, it's slow to load (you almost finish typing before the selector
box opens)

Reproducible: Sometimes

Steps to Reproduce:
1.go to G-mail
2.log in and save password
3.close browsers
4.go to G-mail
5.try to log in

Actual Results:  
Sometimes, it saves my login name
but it no longer auto-fills my password.
Usually, I have to type both.

Expected Results:  
auto-completed info

Problems occur more often on session-based webpages.
If I clear out my saved password for G-mail, it asks me if I want to save it
again when I revisit, even though it no longer auto-completes it (it did in last
week's software).
G-mail no longer completes my login name, even though it recognizes that I have
a stored password (but won't auto-fill it)
Some sites, like Juno.com, it automatically fills in the last login and password
used without even starting to type one in a box.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 2

12 years ago
Every since I upgraded to Firefox 1.0.7, the Password Manager does not work at
the Gmail site https://www.gmail.com/ . 

Once I type the first correct character of my user name I do get an option to
select but once the selection is complete there is no auto-fill of the password
nor is there acknowledgement by the password manager that gives the option to
save or no save the log-in data.

My reviews of saved passwords reveals that the Gmail site is never listed nor is
it listed in Passwords Never Saved.

Comment 3

12 years ago
In the case of Gmail, it has a "autocomplete=off" attribute for the
password-field. So, that's normal.

Comment 4

12 years ago
Referring to comment #3 I presume the issue has been resolved as an acually from start correct behaviour of the browser and will close the bug.

However, if you see this as a general problem in a recent build of Mozilla for other sites not setting this parameter, feel free to return and ask for this bug to be reopened.

Marking INVALID (don't take it personally, Bugzilla doesn't have a politer option ;-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Component: Location Bar and Autocomplete → Password Manager
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.