Dispatch tab events (such as addTab(), removeTab())

RESOLVED DUPLICATE of bug 322898

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 322898
13 years ago
12 years ago

People

(Reporter: Hung Le, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I am working on an extension and interested in knowning when a tab is added or
removed. Currently, it does not appears that such events are propagated (from
looking at "xpfe/global/resources/content/bindings/tabbrowser.xml" 

  . <method name="addTab"> ...
  . <method name="removeTab"> ...



Reproducible: Always

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Server 2003 → All
Hardware: PC → All
Summary: Add event listener for tab events (such as addTab(), removeTab()) → Dispatch tab events (such as addTab(), removeTab())
Version: unspecified → Trunk
Duping to the bug for adding proper events for tab changes.

*** This bug has been marked as a duplicate of 322898 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.