If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Message Filter Log contains entries with blank sender and subject, an incorrect date and a blank message ID

RESOLVED DUPLICATE of bug 287223

Status

MailNews Core
Filters
RESOLVED DUPLICATE of bug 287223
13 years ago
9 years ago

People

(Reporter: jwq, Assigned: Scott MacGregor)

Tracking

Other Branch
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: 

Thunderbird version 1.0 (20041206); Mac OS 10.3.5

 When message filters automatically run on my POP account directly after
automatic message download at startup, the Filter Log contains entries as follows

<p>
Applied filter &quot;Test&quot; to message from  -  at 1970-01-01 09:00:00
Action = Move to folder mailbox://...
 id = 
</p>

which contain a blank sender, subject, an incorrect date and a blank message ID.
If the message filter is run manually, by selecting a filter in the "Message
Filters" dialog and clicking "Run Now" button, the Filter Log entries contain
the correct sender, subject, date and message ID. I have several filters and
this problem is seen with all of them when they execute automatically.


Reproducible: Always

Steps to Reproduce:
1. Set Thunderbird to automatically download messages from a POP account.
2. Create a filter "Test" to move messages from this POP account into a folder
separate from the Inbox. Filter may be based on 'Sender' or 'To' or 'To and CC'.
3. Enable the filter log for the POP account.
4. By any appropriate method, ensure that there are messages which will be
filtered waiting on the POP server to be downloaded.
5. Quit and restart Thunderbird.
6. Open the filter log for the POP account.

Actual Results:  
Filter Log contains incomplete/incorrect log entries as described above.

Expected Results:  
Filter Log entries from automatic filter execution should contain
complete/correct entries, as seen when the filter is executed manually.

Updated

13 years ago
Component: General → MailNews: Filters
Product: Thunderbird → Core
Version: unspecified → Other Branch

Comment 1

13 years ago
This appears to be the same problem as reported in bug 287223 for the WinXP
platform.
(Reporter)

Comment 2

13 years ago
Marking as duplicate of Bug 287223 because David Bienvenu has confirmed and
assigned that bug to himself.

*** This bug has been marked as a duplicate of 287223 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.