<input name="radiobutton" type="radio"> value not posted

RESOLVED EXPIRED

Status

()

Toolkit
Find Toolbar
--
major
RESOLVED EXPIRED
14 years ago
10 years ago

People

(Reporter: davide rampoldi, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
if we just keep the default name that most web editors choose for a radio button
(that is "radiobutton") the real value is not posted.
Instead the value "radiobutton" is posted.

<input name="radiobutton" type="radio" value="1"> should post the value 1, while
it actually gets "radiobutton" ;-)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050113 Firefox/1.0+

WFM

you probably made a mistake in your code.
try the code below, works fine


<html> 
 <head>
 <title></title>
 </head>
 <body>
<form>
 <input type="radio" checked name="radiobutton" value="1"
onclick="document.getElementById('test').innerHTML=this.value">value=1<br>
 <input type="radio" name="radiobutton" value="2"
onclick="document.getElementById('test').innerHTML=this.value">value=2<br>
 <input type="radio" name="radiobutton" value="3"
onclick="document.getElementById('test').innerHTML=this.value">value=3<br>
 <input type="radio" name="radiobutton" value="4"
onclick="document.getElementById('test').innerHTML=this.value">value=4<br>
</form><br>
<span id="test">1</span>
</body>
</html>

Comment 2

14 years ago
Reporter, can you provide a test page and the browser's build identifier? WFM
with a simple ASP.NET test page in both FF 1.0 and Mozilla 1.8a6.
Component: Form Manager → Find Toolbar / FastFind
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.