"Clear button" behind "Subject or Sender contains:" field is disabled

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Ulf Dunkel, Unassigned)

Tracking

({regression})

1.8 Branch
x86
Windows 2000
regression
Bug Flags:
blocking-seamonkey1.0a -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20050112
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20050112

Having updated to Build 2005011204, I realize now that the "Clear" button is no
longer selectable but stays disabled, whatever I do.

Reproducible: Always

Steps to Reproduce:
1. Select a Mail or Newsgroup folder - "Clear" stays disabled.
2. Enter some stuff in "Subject or Sender contains:" - "Clear" stays disabled.
3. Delete the entered stuff - "Clear" stays disabled.

Actual Results:  
The Clear button doesn't change its status.

Expected Results:  
The Clear button should be selectable and accessable with [Alt][C] as it was before.

Comment 1

13 years ago
WFM with a Linux Gtk2 build that just finished compiling.

Have you tried this with a new profile and no extensions installed already?
(Reporter)

Comment 2

13 years ago
WFM too, using Build 2005011204 with a new test profile, without any plugins.
So: Which part is to be blamed?

Comment 3

13 years ago
(In reply to comment #2)
> WFM too, using Build 2005011204 with a new test profile, without any plugins.
> So: Which part is to be blamed?

I don't know. You could try to install the extensions you used one after another
or to find the broken file in your profile (e.g. try deleting the file XUL.mfl).

I mark this bug WFM. Please reopen when you found a way to reproduce it the bug
and you think it is a bug in mozilla (and not in a third-party extension for
example).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

13 years ago
I deactivated all my used plugins one by one (quitting and restarting Mozilla
each time). No change, "Clear" still disabled when I entered text.

Then I renamed my private file XUL.mfl to XUL.mfl_ and restarted Mozilla. No change.

Then I activated all plugins again - and everything is fine now.

What the heck is XUL.mfl and do I need it?

Comment 5

13 years ago
it's just a cache, and it can get corrupted (though I thought that problem had
been fixed). It will get recreated after you delete it.

Comment 6

13 years ago
*** Bug 280800 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
(In reply to comment #5)
> it's just a cache, and it can get corrupted (though I thought that problem had
> been fixed). It will get recreated after you delete it.

Even if this cache recreation process is a workaround, the bug still exists that
makes the workaround necessary.  

I experience this bug now also. I am using (Mozilla/5.0 (Windows; U; Windows NT
5.0; en-US; rv:1.8a6) Gecko/20050111).  The Clear button is never enabled.
(Reporter)

Comment 8

13 years ago
Had this bug the other minute again. It's severe: Mozilla crashed!

- I selected the folder "Sent".
- Then I entered a word in the search field ("Subject or Sender contains"), e.g.
the word "support".
- I moved all mails with "support" to another folder.
- I overwrote the search field with other words and moved the according mails to
other folders.
- The "Clear" button was disabled all the time.
- I then selected the last search word and pressed [Delete] - CRASH.

As I am the reporter, I reopen this bug.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Updated

13 years ago
Severity: minor → major

Comment 9

13 years ago
I had this problem as well.  Deleting the xul.mfl file didn't fix it, but
deleting the chrome\chrome.rdf did.  I had to reapply modern of course, but the
clear button worked at that point in both classic and modern.  Mozilla 1.8b2,
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050220

Comment 10

13 years ago
This has reappeared.  Deleting chrome.rdf and reverting to the classic crome,
the button works, but as soon as I apply modern and restart, the button is
greyed out again.  Something to do with the chrome, or something to do with the
chrome change?

Is anyone else using Modern and having this problem?  Anyone using classic?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Flags: blocking1.8b2?
Keywords: mail4
(Reporter)

Comment 11

13 years ago
I never worked with Modern Style, always with Classic. Have this bug again, too.

Updated

13 years ago
Flags: blocking-seamonkey1.0a?

Comment 12

13 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050326
classic theme, zip build.

Comment 13

13 years ago
We're not holding our alpha release for that one.
Flags: blocking-seamonkey1.0a? → blocking-seamonkey1.0a-

Comment 14

13 years ago
see bug 286367 for a similar bug with consistent steps-to-reproduce
Keywords: regression

Updated

13 years ago
Assignee: sspitzer → mail

Comment 15

12 years ago
(In reply to comment #14)
> see bug 286367 for a similar bug with consistent steps-to-reproduce

Looks like the problematic code is identified there. I wouldn't know. I am not a
programmer of *that* level. But I have this problem, and am using iCandy Junior
theme (http://spuler.us).

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050607.

I don't know whether WFM (works for me) written by many of our friends here
means that they see the bug too or see the absence of the bug. Please explain.
(Reporter)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.0 Branch
Version: 1.0 Branch → 1.8 Branch
You need to log in before you can comment on or make changes to this bug.