IFrame in Floated Div Inacessible

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
28 days ago

People

(Reporter: louis, Assigned: roc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If you nest an IFrame within a Div which has a float left or right style then
you cannot interact with the IFrame (eg click links, highlight text etc).

I have verified that Internet Explorer, Opera and Konqueror all handle this
situation correctly.



Reproducible: Always

Steps to Reproduce:
1. Visit the mock up page I created at http://www.6internet.com/firefox-bug/ 
2. Try to click the links in the left hand IFrame, or highlight any text
3. View the source and observe the IFrame is within a Div floated left

Actual Results:  
Cannot use the IFrame

Expected Results:  
Should have behaved just like the right hand IFrame which is also nested in a
Div, but whose Div is not floated.  I have verified that Internet Explorer,
Opera and Konqueror all handle this situation correctly.
with 

#IframeDivLeft {
	float:left;
	}

#IframeDivRight {
	float:left;
	padding-left:10px;
	}

it works fine in Opera, IE and Moz/FF
Your example is different in every browser

Comment 2

14 years ago
This happends because the second iframe is above the left one. Add
margin-left:295px and to the second div and it will not be above.

I think there is already a bug filed about this, that click should work anyway. 

Comment 3

14 years ago
See Bug 102695.

Updated

14 years ago
Assignee: firefox → roc
Component: General → Layout: View Rendering
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → ian
Hardware: PC → All
Version: unspecified → Trunk
This is partly bug 102695, about whether and when elements should be transparent
to events. But I think you also misunderstand your testcase. Your 'z-index:100'
rule is not taking effect because z-index only applies to positioned elements
and that element is not positioned. So IFrameDivRight is on top and in fact
covers all of IFrameDivLeft.

Anyway, what we are doing is reasonable (modulo bug 102695).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.